<!DOCTYPE html><html class="html" lang="en-US" prefix="og: http://ogp.me/ns#" itemscope itemtype="http://schema.org/WebPage"><head><meta charset="UTF-8">
<script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=(function(){var pixels=[],pxURL="/porpoiseant/army.gif";function AddAndFirePixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0);Fire();}
function GetCurrentPixels(){return pixels;}
function AddPixel(adSlot,pixelData,revenue,est_revenue,bid_floor_filled,bid_floor_prev,stat_source_id){if(!__ez.dot.isDefined(adSlot)||__ez.dot.isAnyDefined(adSlot.getSlotElementId,adSlot.ElementId)==false){return;}
var ad_position_id=parseInt(__ez.dot.getTargeting(adSlot,'ap'));var impId=__ez.dot.getSlotIID(adSlot),adUnit=__ez.dot.getAdUnit(adSlot);var compId=parseInt(__ez.dot.getTargeting(adSlot,"compid"));var lineItemId=0;var creativeId=0;var ezimData=getEzimData(adSlot);if(typeof ezimData=='object'){if(ezimData.creative_id!==undefined){creativeId=ezimData.creative_id;}
if(ezimData.line_item_id!==undefined){lineItemId=ezimData.line_item_id;}}
if(__ez.dot.isDefined(impId,adUnit)&&__ez.dot.isValid(pixelData)){pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),revenue:revenue,est_revenue:est_revenue,ad_position:ad_position_id,ad_size:"",bid_floor_filled:bid_floor_filled,bid_floor_prev:bid_floor_prev,stat_source_id:stat_source_id,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:compId,line_item_id:lineItemId,creative_id:creativeId,data:__ez.dot.dataToStr(pixelData)});}}
function AddPixelById(impFullId,pixelData){var vals=impFullId.split('/');if(__ez.dot.isDefined(impFullId)&&vals.length===3&&__ez.dot.isValid(pixelData)){var adUnit=vals[0],impId=vals[2];pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(pixelData)});}}
function Fire(){if(typeof document.visibilityState!=='undefined'&&document.visibilityState==="prerender")return;if(__ez.dot.isDefined(pixels)&&pixels.length>0){while(pixels.length>0){var j=5;if(j>pixels.length){j=pixels.length;}
var pushPixels=pixels.splice(0,j);var pixelURL=__ez.dot.getURL(pxURL)+"?orig="+(__ez.template.isOrig===true?1:0)+"&sts="+btoa(JSON.stringify(pushPixels));if(typeof window.isAmp!=='undefined'&&isAmp&&typeof window._ezaq!=='undefined'&&_ezaq.hasOwnProperty("domain_id")){pixelURL+="&visit_uuid="+_ezaq['visit_uuid'];}
(new Image()).src=pixelURL;}}
pixels=[];}
function getEzimData(adSlot){if(typeof _ezim_d=="undefined"){return false}
var adUnitName=__ez.dot.getAdUnitPath(adSlot).split('/').pop();if(typeof _ezim_d==='object'&&_ezim_d.hasOwnProperty(adUnitName)){return _ezim_d[adUnitName];}
for(var ezimKey in _ezim_d){if(ezimKey.split('/').pop()===adUnitName){return _ezim_d[ezimKey];}}
return false;}
return{Add:AddPixel,AddAndFire:AddAndFirePixel,AddById:AddPixelById,Fire:Fire,GetPixels:GetCurrentPixels,};})();__ez.queue.addFile('/detroitchicago/raleigh.js', '/detroitchicago/raleigh.js?gcb=191-0&cb=1', false, [], true, false, true, false);__ez.queue.addFile('/detroitchicago/tampa.js', '/detroitchicago/tampa.js?gcb=191-0&cb=1', false, [], true, false, true, false);</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">__ez.queue.addFile('/detroitchicago/tulsa.js', '/detroitchicago/tulsa.js?gcb=191-0&cb=2', false, [], true, false, true, false);</script><link rel="profile" href="https://gmpg.org/xfn/11"><link type="text/css" media="all" href="https://net2.com/wp-content/cache/autoptimize/css/autoptimize_64b3003b0ee32be3a4f5e9255401dce4.css" rel="stylesheet" /><title>How to fix sound issues on Ubuntu 18.04</title><meta name="viewport" content="width=device-width, initial-scale=1"><meta name="description" content="Ubuntu 18.04 was possibly the most compatible and powerful of all Ubuntu versions. There are however some sound problems with certain types of hardware or"/><link rel="canonical" href="https://net2.com/how-to-fix-sound-issues-on-ubuntu-18-04/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="How to fix sound issues on Ubuntu 18.04" /><meta property="og:description" content="Ubuntu 18.04 was possibly the most compatible and powerful of all Ubuntu versions. There are however some sound problems with certain types of hardware or" /><meta property="og:url" content="https://net2.com/how-to-fix-sound-issues-on-ubuntu-18-04/" /><meta property="og:site_name" content="net2" /><meta property="article:tag" content="alsamixer" /><meta property="article:tag" content="pavucontrol" /><meta property="article:tag" content="pulseaudio" /><meta property="article:section" content="Linux" /><meta property="article:published_time" content="2020-07-20T11:07:00+02:00" /><meta property="article:modified_time" content="2020-09-19T11:29:33+02:00" /><meta property="og:updated_time" content="2020-09-19T11:29:33+02:00" /><meta property="og:image" content="https://net2.com/wp-content/uploads/2020/07/How-to-fix-sound-issues-on-Ubuntu-18.jpg" /><meta property="og:image:secure_url" content="https://net2.com/wp-content/uploads/2020/07/How-to-fix-sound-issues-on-Ubuntu-18.jpg" /><meta property="og:image:width" content="400" /><meta property="og:image:height" content="222" /><meta property="og:image:alt" content="How to fix sound issues on Ubuntu 18.04" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:description" content="Ubuntu 18.04 was possibly the most compatible and powerful of all Ubuntu versions. There are however some sound problems with certain types of hardware or" /><meta name="twitter:title" content="How to fix sound issues on Ubuntu 18.04" /><meta name="twitter:image" content="https://net2.com/wp-content/uploads/2020/07/How-to-fix-sound-issues-on-Ubuntu-18.jpg" /> <script type='application/ld+json'>{"@context":"https:\/\/schema.org","@type":"Organization","url":"https:\/\/net2.com\/","sameAs":[],"@id":"https:\/\/net2.com\/#organization","name":"net2","logo":"https:\/\/net2.com\/wp-content\/uploads\/2019\/08\/LOGO-net2.png"}</script> <link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="net2 &raquo; Feed" href="https://net2.com/feed/" /><link rel="alternate" type="application/rss+xml" title="net2 &raquo; Comments Feed" href="https://net2.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="net2 &raquo; How to fix sound issues on Ubuntu 18.04 Comments Feed" href="https://net2.com/how-to-fix-sound-issues-on-ubuntu-18-04/feed/" />  <script type="text/javascript" data-cfasync="false">var mi_version         = '7.12.2';
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-146071783-1';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}

	if ( 'undefined' === typeof gaOptout ) {
		function gaOptout() {
			__gaTrackerOptout();
		}
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

		__gaTracker('create', 'UA-146071783-1', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('require', 'displayfeatures');
		__gaTracker('require', 'linkid', 'linkid.js');
		__gaTracker('send','pageview');
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}</script>  <script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/net2.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.4"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);</script> <link rel='stylesheet' id='oceanwp-style-css'  href='https://net2.com/wp-content/uploads/oceanwp/main-style.css?ver=1.7.4' type='text/css' media='all' /> <script type='text/javascript'>var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"}]","home_url":"https:\/\/net2.com","hash_tracking":"false"};</script> <script type='text/javascript' src='https://net2.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend.min.js?ver=7.12.2'></script> <script type='text/javascript' src='https://net2.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script> <script type='text/javascript' src='https://net2.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script> <script type='text/javascript' src='https://net2.com/wp-content/plugins/add-to-any/addtoany.min.js?ver=1.1'></script> <script type='text/javascript'>var wpp_params = {"sampling_active":"0","sampling_rate":"100","ajax_url":"https:\/\/net2.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","ID":"5069","token":"1bd60e4276","debug":""};</script> <script type='text/javascript' src='https://net2.com/wp-content/plugins/wordpress-popular-posts/assets/js/wpp-5.0.0.min.js?ver=5.1.0'></script> <link rel='https://api.w.org/' href='https://net2.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://net2.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://net2.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.3.4" /><link rel='shortlink' href='https://net2.com/?p=5069' /><link rel="alternate" type="application/json+oembed" href="https://net2.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnet2.com%2Fhow-to-fix-sound-issues-on-ubuntu-18-04%2F" /><link rel="alternate" type="text/xml+oembed" href="https://net2.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnet2.com%2Fhow-to-fix-sound-issues-on-ubuntu-18-04%2F&#038;format=xml" /> <script data-cfasync="false">window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};
(function(d,s,a,b){a=d.createElement(s);b=d.getElementsByTagName(s)[0];a.async=1;a.src="https://static.addtoany.com/menu/page.js";b.parentNode.insertBefore(a,b);})(document,"script");</script> <script data-ad-client="ca-pub-4222719099368092" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <meta name="onesignal" content="wordpress-plugin"/> <script>window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
        OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
        OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };

        OneSignal.setDefaultNotificationUrl("https://net2.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = '816f511e-5922-47a9-9e88-570bf32478fa';
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "";
oneSignal_options['welcomeNotification']['message'] = "";
oneSignal_options['path'] = "https://net2.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.245258f0-6c6a-439f-986f-895149dbff04";
oneSignal_options['persistNotification'] = true;
oneSignal_options['promptOptions'] = { };
oneSignal_options['notifyButton'] = { };
oneSignal_options['notifyButton']['enable'] = true;
oneSignal_options['notifyButton']['position'] = 'bottom-right';
oneSignal_options['notifyButton']['theme'] = 'default';
oneSignal_options['notifyButton']['size'] = 'medium';
oneSignal_options['notifyButton']['showCredit'] = true;
oneSignal_options['notifyButton']['text'] = {};
                OneSignal.init(window._oneSignalInitOptions);
                OneSignal.showSlidedownPrompt();      });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }</script> <link rel="icon" href="https://net2.com/wp-content/uploads/2019/08/LOGO-ICON-net2.png" sizes="32x32" /><link rel="icon" href="https://net2.com/wp-content/uploads/2019/08/LOGO-ICON-net2.png" sizes="192x192" /><link rel="apple-touch-icon-precomposed" href="https://net2.com/wp-content/uploads/2019/08/LOGO-ICON-net2.png" /><meta name="msapplication-TileImage" content="https://net2.com/wp-content/uploads/2019/08/LOGO-ICON-net2.png" />
<script data-ezscrex="false" data-cfasync="false" type="text/javascript">window.google_analytics_uacct = "UA-161946693-23";</script>
<script data-ezscrex="false" data-cfasync="false" type="text/javascript">
var _gaq = _gaq || [];
_gaq.push(function(){
	_gat._createTracker('UA-161946693-23', 'e');
});
_gaq.push(function(){
	_gat._createTracker('UA-38339005-1', 'f');
});
_gaq.push(['e._setDomainName', 'net2.com']);
_gaq.push(['f._setDomainName', 'net2.com']);
_gaq.push(['e._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['e._setCustomVar',2,'t','126',3]);
_gaq.push(['e._setCustomVar',3,'rid','0',2]);
_gaq.push(['e._setCustomVar',4,'bra','mod1',3]);
_gaq.push(['e._setAllowAnchor',true]);
_gaq.push(['e._setSiteSpeedSampleRate', 10]);
_gaq.push(['f._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['f._setCustomVar',2,'domain','net2.com',3]);
_gaq.push(['f._setSiteSpeedSampleRate', 20]);
_gaq.push(['e._trackPageview']);
_gaq.push(['f._trackPageview']);


(function() {
 var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
 ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
 var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
})();
</script>
<script type="text/javascript">var ezouid = "1";</script><base href="https://net2.com/how-to-fix-sound-issues-on-ubuntu-18-04/"><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script><!-- START EZHEAD -->
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 190025;
var ezdomain = 'net2.com';
var ezoicSearchable = 1;
</script>
<!--{jquery}-->
<!-- END EZHEAD -->
<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":190025,"engaged_time_visit":0,"ezcache_level":2,"forensiq_score":-1,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"fb83221b-6ce9-4017-7f29-0aa2407887cd","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_time_orig":4,"serverid":"54.198.205.158:25120","state":"VA","t_epoch":1601186194,"template_id":126,"time_on_site_visit":0,"url":"https://net2.com/how-to-fix-sound-issues-on-ubuntu-18-04/","user_id":0,"word_count":1548,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script><script data-ezscrex='false' data-cfasync='false' type="text/javascript" src="/detroitchicago/rochester.js?cb=191-0&v=9" async></script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_190025=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["fb83221b-6ce9-4017-7f29-0aa2407887cd", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script></head><body class="post-template-default single single-post postid-5069 single-format-standard wp-custom-logo wp-embed-responsive no-lightbox oceanwp-theme sidebar-mobile default-breakpoint has-sidebar content-right-sidebar post-in-category-debian post-in-category-linux post-in-category-linux_mint post-in-category-troubleshooting post-in-category-ubuntu page-header-disabled has-blog-grid"><div id="outer-wrap" class="site clr"><div id="wrap" class="clr"><header id="site-header" class="minimal-header clr" data-height="74" itemscope="itemscope" itemtype="http://schema.org/WPHeader"><div id="site-header-inner" class="clr container"><div id="site-logo" class="clr" itemscope itemtype="http://schema.org/Brand"><div id="site-logo-inner" class="clr"> <a href="https://net2.com/" class="custom-logo-link" rel="home" data-wpel-link="internal"><img width="153" height="89" src="https://net2.com/wp-content/uploads/2019/08/cropped-LOGO-net2.png" class="custom-logo" alt="net2" srcset="https://net2.com/wp-content/uploads/2019/08/cropped-LOGO-net2.png 1x, https://net2.com/wp-content/uploads/2019/08/LOGO-net2.png 2x" /></a></div></div><div id="site-navigation-wrap" class="clr"><nav id="site-navigation" class="navigation main-navigation clr" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement"><ul id="menu-main_menu" class="main-menu dropdown-menu sf-menu"><li id="menu-item-23" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-23"><a href="https://net2.com/" class="menu-link" data-wpel-link="internal"><span class="text-wrap">Home</span></a></li><li id="menu-item-2460" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children dropdown menu-item-2460"><a href="https://net2.com/category/linux/" class="menu-link" data-wpel-link="internal"><span class="text-wrap">Linux <span class="nav-arrow fa fa-angle-down"></span></span></a><ul class="sub-menu"><li id="menu-item-1236" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1236"><a href="https://net2.com/category/linux/ubuntu_tips_and_tricks/" class="menu-link" data-wpel-link="internal"><span class="text-wrap">Linux Tips &#038; Tricks</span></a></li><li id="menu-item-2459" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-2459"><a href="https://net2.com/category/troubleshooting/" class="menu-link" data-wpel-link="internal"><span class="text-wrap">Troubleshooting</span></a></li><li id="menu-item-2457" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2457"><a href="https://net2.com/category/maintenance-and-monitoring/" class="menu-link" data-wpel-link="internal"><span class="text-wrap">Maintenance and monitoring</span></a></li></ul></li><li id="menu-item-5372" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5372"><a href="https://net2.com/category/windows/" class="menu-link" data-wpel-link="internal"><span class="text-wrap">Windows</span></a></li><li id="menu-item-3690" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3690"><a href="https://net2.com/category/best-software/" class="menu-link" data-wpel-link="internal"><span class="text-wrap">Best Software</span></a></li><li id="menu-item-2458" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2458"><a href="https://net2.com/category/installations/" class="menu-link" data-wpel-link="internal"><span class="text-wrap">Installations</span></a></li><li id="menu-item-3165" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3165"><a href="https://net2.com/category/computer-and-health/" class="menu-link" data-wpel-link="internal"><span class="text-wrap">Computer and Health</span></a></li><li id="menu-item-3044" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3044"><a href="https://net2.com/category/web_hosting/" class="menu-link" data-wpel-link="internal"><span class="text-wrap">Web hosting|VPN</span></a></li><li class="search-toggle-li"><a href="#" class="site-search-toggle search-dropdown-toggle"><span class="icon-magnifier"></span></a></li></ul><div id="searchform-dropdown" class="header-searchform-wrap clr"><form method="get" class="searchform" id="searchform" action="https://net2.com/"> <input type="text" class="field" name="s" id="s" placeholder="Search"> <input type="hidden" name="post_type" value="post"></form></div></nav></div><div class="oceanwp-mobile-menu-icon clr mobile-right"> <a href="#" class="mobile-menu"> <i class="fa fa-bars"></i> <span class="oceanwp-text">Menu</span> </a></div></div></header><main id="main" class="site-main clr" ><div id="content-wrap" class="container clr"><div id="primary" class="content-area clr"><div id="content" class="site-content clr"><article id="post-5069"><header class="entry-header clr"><h1 class="single-post-title entry-title" itemprop="headline">How to fix sound issues on Ubuntu 18.04</h1></header><ul class="meta clr"><li class="meta-author" itemprop="name"><i class="icon-user"></i><a href="https://net2.com/author/noost/" title="Posts by Nikolaus Oosterhof" rel="author" itemprop="author" itemscope="itemscope" itemtype="http://schema.org/Person" data-wpel-link="internal">Nikolaus Oosterhof</a></li><li class="meta-date" itemprop="datePublished"><i class="icon-clock"></i>July 20, 2020</li><li class="meta-cat"><i class="icon-folder"></i><a href="https://net2.com/category/linux/debian/" rel="category tag" data-wpel-link="internal">Debian</a> <span class="owp-sep">/</span> <a href="https://net2.com/category/linux/" rel="category tag" data-wpel-link="internal">Linux</a> <span class="owp-sep">/</span> <a href="https://net2.com/category/linux/linux_mint/" rel="category tag" data-wpel-link="internal">Linux Mint</a> <span class="owp-sep">/</span> <a href="https://net2.com/category/troubleshooting/" rel="category tag" data-wpel-link="internal">Troubleshooting</a> <span class="owp-sep">/</span> <a href="https://net2.com/category/linux/ubuntu/" rel="category tag" data-wpel-link="internal">Ubuntu</a></li><li class="meta-comments"><i class="icon-bubble"></i><a href="https://net2.com/how-to-fix-sound-issues-on-ubuntu-18-04/#respond" class="comments-link local" data-wpel-link="internal">0 Comments</a></li></ul><div class="entry-content clr" itemprop="text"><p><span style="color: #000000;">Ubuntu 18.04 was possibly the most compatible and powerful of all Ubuntu versions. There are however some sound problems with certain types of hardware or even configurations.</span><span id="more-5069"></span></p><p><span style="color: #000000;">These problems are common on Linux distros but in most cases, they are easy to solve.</span></p><p><span style="color: #000000;">Sometimes they may be related to a bad configuration of the speaker settings, or to a non supported hardware.</span></p><p><span style="color: #000000;">In this tutorial, we will outline some of the most common solutions that might help fix sound issues on your Ubuntu 18.04 system.</span></p><h2><span style="color: #000000;"><a id="post-5069-_z6eykie6tau5" style="color: #000000;"></a>Sound devices not detected</span></h2><p><span style="color: #000000;">Sometimes, especially when you upgrade from a previous version onto a higher LTS version like Ubuntu 18.04, sound devices cannot be detected as shown in the snapshot below :</span></p><p><span style="color: #000000;">For the output devices:</span></p><p><span style="color: #000000;"><img class="wp-image-5070 aligncenter" src="https://net2.com/wp-content/uploads/2020/07/word-image-26.jpeg" width="540" height="392" srcset="https://net2.com/wp-content/uploads/2020/07/word-image-26.jpeg 1344w, https://net2.com/wp-content/uploads/2020/07/word-image-26-300x217.jpeg 300w, https://net2.com/wp-content/uploads/2020/07/word-image-26-1024x742.jpeg 1024w, https://net2.com/wp-content/uploads/2020/07/word-image-26-768x557.jpeg 768w" sizes="(max-width: 540px) 100vw, 540px" /></span></p><p style="text-align: center;"><span style="color: #000000; font-size: 8pt;">Ubuntu sound not working</span></p><p><span style="color: #000000;">Or the Input devices:</span></p><p><span style="color: #000000;"><img class="wp-image-5071 aligncenter" src="https://net2.com/wp-content/uploads/2020/07/word-image-27.jpeg" width="564" height="367" srcset="https://net2.com/wp-content/uploads/2020/07/word-image-27.jpeg 1562w, https://net2.com/wp-content/uploads/2020/07/word-image-27-300x196.jpeg 300w, https://net2.com/wp-content/uploads/2020/07/word-image-27-1024x667.jpeg 1024w, https://net2.com/wp-content/uploads/2020/07/word-image-27-768x501.jpeg 768w, https://net2.com/wp-content/uploads/2020/07/word-image-27-1536x1001.jpeg 1536w" sizes="(max-width: 564px) 100vw, 564px" /></span></p><p style="text-align: center;"><span style="font-size: 8pt;">Ubuntu no sound issue</span></p><p><span style="color: #000000;">In such situations, it might be related to a permission issue with the pulseaudio config file. Try to run the commands below in order to fix this :</span></p><p><span style="color: #000000; font-family: 'courier new', courier, monospace;">killall pulseaudio; rm -r ~/.config/pulse/*</span></p><h2><span style="color: #000000;"><a id="post-5069-_mhtzrpwsdhkj" style="color: #000000;"></a>Selection of the correct sound device</span></h2><p><span style="color: #000000;">Some Linux computers have several sound devices installed. Some of these devices are able to output sound yet some others do not. You should therefore ensure by trial and error that the correct sound device is selected. In order to do this, follow the steps below :</span></p><p><span style="color: #000000;">Open up the Activities overview screen and type in ‘Sound’. Next click on the Sound icon to open the panel.</span></p><p><span style="color: #000000;"><img class="wp-image-5072 aligncenter" src="https://net2.com/wp-content/uploads/2020/07/word-image-28.jpeg" width="500" height="411" srcset="https://net2.com/wp-content/uploads/2020/07/word-image-28.jpeg 1234w, https://net2.com/wp-content/uploads/2020/07/word-image-28-300x247.jpeg 300w, https://net2.com/wp-content/uploads/2020/07/word-image-28-1024x843.jpeg 1024w, https://net2.com/wp-content/uploads/2020/07/word-image-28-768x632.jpeg 768w" sizes="(max-width: 500px) 100vw, 500px" /></span></p><p><span style="color: #000000;">On the Output tab, select a device and modify the Profile settings. Now try to play a sound to check if it operates properly. If this is not successful, try to select another device and change the profile.</span></p><p><span style="color: #0000ff;"><a style="color: #0000ff;" href="http://net2.com/how-manage-sounds-using-pulseaudio-on-ubuntu-18-04" data-wpel-link="internal">Read: How to manage sound on Ubuntu 18.04</a></span></p><h2><span style="color: #000000;"><a id="post-5069-_swphy8pd1his" style="color: #000000;"></a>Is the sound muted ?</span></h2><p><span style="color: #000000;">It might seem unlikely, but sometimes, the sound might be muted. Make sure this is not the case by checking the volume icon on the system menu.</span></p><p><span style="color: #000000;"><strong><img class="wp-image-5073 aligncenter" src="https://net2.com/wp-content/uploads/2020/07/word-image-7.png" width="173" height="172" srcset="https://net2.com/wp-content/uploads/2020/07/word-image-7.png 612w, https://net2.com/wp-content/uploads/2020/07/word-image-7-300x300.png 300w, https://net2.com/wp-content/uploads/2020/07/word-image-7-150x150.png 150w" sizes="(max-width: 173px) 100vw, 173px" /></strong></span></p><p><span style="color: #000000;">Some computers have mute keys or switches on their keyboards. You might want to press that key in order to see if it unmutes the sound.</span></p><p><span style="color: #000000;">There could be also some applications that have a built-in volume or mute button. You might want to check that you have not mistakenly muted the media application you are using to play sound (.e.g. Rhythmbox or music player).</span></p><p><span style="color: #0000ff;">Read: <a style="color: #0000ff;" href="https://net2.com/how-to-speed-up-linux/" target="_blank" rel="noopener noreferrer" data-wpel-link="internal">How to speed up Linux</a></span></p><p><span style="color: #000000;">You might also want to check, under the Sound section, the Applications tab. To do this, open up the Activities overview and type in ‘Sound’. Now click on Sound to open the panel.</span></p><p><span style="color: #000000;">Select the Applications tab and make sure the sound level is not set to low or not off.</span></p><p><span style="color: #000000;"><strong><img class="wp-image-5074 aligncenter" src="https://net2.com/wp-content/uploads/2020/07/word-image-29.jpeg" width="415" height="353" srcset="https://net2.com/wp-content/uploads/2020/07/word-image-29.jpeg 806w, https://net2.com/wp-content/uploads/2020/07/word-image-29-300x255.jpeg 300w, https://net2.com/wp-content/uploads/2020/07/word-image-29-768x654.jpeg 768w" sizes="(max-width: 415px) 100vw, 415px" /></strong></span></p><h2><span style="color: #000000;"><a id="post-5069-_7lniv6jl4422" style="color: #000000;"></a>Sound card detection</span></h2><p><span style="color: #000000;">When the relevant drivers are not installed, the sound card may not be detected properly. In such circumstances, the drivers would need to be installed manually. This may depend on the sound card type though. You would need to run the lspci command to find out the type of your sound card :</span></p><p><span style="color: #000000;">Open up the terminal and run lspci as root:</span></p><p><span style="color: #000000; font-family: 'courier new', courier, monospace;">sudo lspci</span></p><p><span style="color: #000000;"><img class="wp-image-5075 aligncenter" src="https://net2.com/wp-content/uploads/2020/07/word-image-30.jpeg" width="502" height="241" srcset="https://net2.com/wp-content/uploads/2020/07/word-image-30.jpeg 1554w, https://net2.com/wp-content/uploads/2020/07/word-image-30-300x144.jpeg 300w, https://net2.com/wp-content/uploads/2020/07/word-image-30-1024x492.jpeg 1024w, https://net2.com/wp-content/uploads/2020/07/word-image-30-768x369.jpeg 768w, https://net2.com/wp-content/uploads/2020/07/word-image-30-1536x737.jpeg 1536w" sizes="(max-width: 502px) 100vw, 502px" /></span></p><p><span style="color: #000000;">Check if an audio device or an audio controller is displayed. If this is the case, jot down the make and the model number of the corresponding sound card. Note that the command :</span></p><p><span style="color: #000000; font-family: 'courier new', courier, monospace;">lspci -v</span></p><p><span style="color: #000000;">Will provide more details about the listed controllers.</span></p><p><span style="color: #000000;">Now that you have the information about your sound card, try to visit the maker website to check if they have suitable drivers for your system. You may also want to ask on support forums as well.</span></p><p><span style="color: #000000;">This <span style="color: #0000ff;"><a style="color: #0000ff;" href="https://net2.com/must-do-things-after-installing-ubuntu-18-04/" data-wpel-link="internal">article</a></span> will help you install the latest drivers.</span></p><h2><span style="color: #000000;"><a id="post-5069-_l784z5xbdkm4" style="color: #000000;"></a>Pavucontrol installation</span></h2><p><span style="color: #000000;">Since PulseAudio doesn’t allow to control each playback stream separately, Pavucontrol provides you with more control over your audio devices, so that you will be able to tweak your headphone or speaker more precisely.</span></p><p><span style="color: #000000;"><img class="wp-image-5076 aligncenter" src="https://net2.com/wp-content/uploads/2020/07/word-image-31.jpeg" width="462" height="267" srcset="https://net2.com/wp-content/uploads/2020/07/word-image-31.jpeg 1476w, https://net2.com/wp-content/uploads/2020/07/word-image-31-300x174.jpeg 300w, https://net2.com/wp-content/uploads/2020/07/word-image-31-1024x592.jpeg 1024w, https://net2.com/wp-content/uploads/2020/07/word-image-31-768x444.jpeg 768w" sizes="(max-width: 462px) 100vw, 462px" /></span></p><p><span style="color: #000000;">Pavucontrol can be installed using the following commands:</span></p><p><span style="color: #000000; font-family: 'courier new', courier, monospace;">pulseaudio &#8211;start</span></p><p><span style="color: #000000; font-family: 'courier new', courier, monospace;">sudo apt-get install pavucontrol</span></p><p><span style="color: #000000;">Next run pavucontrol and under Output Devices, ensure your default speakers are currently selected.</span></p><p><span style="color: #000000;"><img class="wp-image-5077 aligncenter" src="https://net2.com/wp-content/uploads/2020/07/word-image-32.jpeg" width="440" height="241" srcset="https://net2.com/wp-content/uploads/2020/07/word-image-32.jpeg 1558w, https://net2.com/wp-content/uploads/2020/07/word-image-32-300x164.jpeg 300w, https://net2.com/wp-content/uploads/2020/07/word-image-32-1024x561.jpeg 1024w, https://net2.com/wp-content/uploads/2020/07/word-image-32-768x421.jpeg 768w, https://net2.com/wp-content/uploads/2020/07/word-image-32-1536x842.jpeg 1536w" sizes="(max-width: 440px) 100vw, 440px" /></span></p><p><span style="color: #000000;">In your configuration tab, set the profile to Analog Stereo Output :</span></p><p><span style="color: #000000;"><img class="wp-image-5078 aligncenter" src="https://net2.com/wp-content/uploads/2020/07/word-image-33.jpeg" width="484" height="263" srcset="https://net2.com/wp-content/uploads/2020/07/word-image-33.jpeg 1558w, https://net2.com/wp-content/uploads/2020/07/word-image-33-300x163.jpeg 300w, https://net2.com/wp-content/uploads/2020/07/word-image-33-1024x557.jpeg 1024w, https://net2.com/wp-content/uploads/2020/07/word-image-33-768x418.jpeg 768w, https://net2.com/wp-content/uploads/2020/07/word-image-33-1536x836.jpeg 1536w" sizes="(max-width: 484px) 100vw, 484px" /></span></p><h2><span style="color: #000000;"><a id="post-5069-_ho9n8wj2s0mu" style="color: #000000;"></a>Speaker settings</span></h2><p><span style="color: #000000;">If your machine has external speakers, you would need to ensure that they are working properly and that the volume is not at its lowest, or is not turned off. Make sure also that your speaker cable is plugged into the correct output audio socket (light green) of your computer since the audio cable could be connected to the wrong port or even not connected at all.</span></p><p><span style="color: #000000;"><img class="wp-image-5079 aligncenter" src="https://net2.com/wp-content/uploads/2020/07/word-image-34.jpeg" width="520" height="380" srcset="https://net2.com/wp-content/uploads/2020/07/word-image-34.jpeg 1352w, https://net2.com/wp-content/uploads/2020/07/word-image-34-300x219.jpeg 300w, https://net2.com/wp-content/uploads/2020/07/word-image-34-1024x748.jpeg 1024w, https://net2.com/wp-content/uploads/2020/07/word-image-34-768x561.jpeg 768w" sizes="(max-width: 520px) 100vw, 520px" /></span></p><p><span style="color: #000000;">This might seem straightforward but it is worth checking it out: try to see that the audio cable is plugged into the correct input socket of your speaker since these may have more than one input socket.</span></p><p><span style="color: #000000;">If you have a Bluetooth device, make sure it is paired up correctly also.</span></p><h2><span style="color: #000000;"><a id="post-5069-_va8b50buamqd" style="color: #000000;"></a>Alsamixer</span></h2><p><span style="color: #000000;">This might seem unlikely but it could be that all the audio volume controls are at their highest levels yet you don&#8217;t hear anything. This might be related to the mixer control settings. In order to find out if this is the case, you would need to run alsamixer on your terminal as follows :</span></p><p><span style="color: #000000;">Type in : </span></p><p><span style="color: #000000; font-family: 'courier new', courier, monospace;">alsamixer</span></p><p><span style="color: #000000;"><img class="wp-image-5080 aligncenter" src="https://net2.com/wp-content/uploads/2020/07/word-image-8.png" width="552" height="69" srcset="https://net2.com/wp-content/uploads/2020/07/word-image-8.png 1464w, https://net2.com/wp-content/uploads/2020/07/word-image-8-300x37.png 300w, https://net2.com/wp-content/uploads/2020/07/word-image-8-1024x127.png 1024w, https://net2.com/wp-content/uploads/2020/07/word-image-8-768x95.png 768w" sizes="(max-width: 552px) 100vw, 552px" /></span></p><p><span style="color: #000000;">This will display the screen below :</span></p><p><span style="color: #000000;"><img class="wp-image-5081 aligncenter" src="https://net2.com/wp-content/uploads/2020/07/word-image-35.jpeg" width="490" height="307" srcset="https://net2.com/wp-content/uploads/2020/07/word-image-35.jpeg 1320w, https://net2.com/wp-content/uploads/2020/07/word-image-35-300x188.jpeg 300w, https://net2.com/wp-content/uploads/2020/07/word-image-35-1024x642.jpeg 1024w, https://net2.com/wp-content/uploads/2020/07/word-image-35-768x482.jpeg 768w" sizes="(max-width: 490px) 100vw, 490px" /></span></p><p style="text-align: center;"><span style="color: #000000; font-size: 8pt;">No sound on Ubuntu</span></p><table style="height: 18px;" width="39"><tbody><tr><td></td></tr></tbody></table><p><span style="color: #000000;">In the upper part you can find the details of your card. In the central part, you can view the current levels configuration. Pressing the F6 key will let choose the sound card.</span></p><p><span style="color: #000000;">As you can see above, the Headphone bar was muted despite the fact that the Master bar was already at its maximum level. This might explain your audio issue in case you found the same setting. In order to solve this, simply use the left/right arrow keys to highlight/select the headphones tab. Next use the up/down arrow keys to raise/lower the volume. Finally exit the interface by pressing the ESC key.</span></p><p><span style="color: #000000;">You may have noticed that MM is displayed below the volume bar when a mixer control is muted. You can unmute a specific control using the m key. This will change the MM to OO.</span></p><p><span style="color: #000000;">You can also adjust the volume using the following commands on your terminal:</span></p><p><span style="color: #000000; font-family: 'courier new', courier, monospace;">amixer set Master 50%</span></p><p><span style="color: #000000;"><img class="wp-image-5082 aligncenter" src="https://net2.com/wp-content/uploads/2020/07/word-image-36.jpeg" width="577" height="146" srcset="https://net2.com/wp-content/uploads/2020/07/word-image-36.jpeg 1554w, https://net2.com/wp-content/uploads/2020/07/word-image-36-300x76.jpeg 300w, https://net2.com/wp-content/uploads/2020/07/word-image-36-1024x260.jpeg 1024w, https://net2.com/wp-content/uploads/2020/07/word-image-36-768x195.jpeg 768w, https://net2.com/wp-content/uploads/2020/07/word-image-36-1536x389.jpeg 1536w" sizes="(max-width: 577px) 100vw, 577px" /></span></p><p><span style="color: #000000;">To find out more about the amixer command, simply type in :</span></p><p><span style="color: #000000; font-family: 'courier new', courier, monospace;">amixer</span></p><p><span style="color: #000000;"><img class="wp-image-5083 aligncenter" src="https://net2.com/wp-content/uploads/2020/07/word-image-37.jpeg" width="507" height="376" srcset="https://net2.com/wp-content/uploads/2020/07/word-image-37.jpeg 1358w, https://net2.com/wp-content/uploads/2020/07/word-image-37-300x222.jpeg 300w, https://net2.com/wp-content/uploads/2020/07/word-image-37-1024x759.jpeg 1024w, https://net2.com/wp-content/uploads/2020/07/word-image-37-768x569.jpeg 768w" sizes="(max-width: 507px) 100vw, 507px" /></span></p><p><span style="color: #000000;">In the next section, you will see how to reset or reload alsa in case it was misconfigured or it has other unidentified issues.</span></p><p><span style="color: #000000;">if the sound problem persists, try to reload ALSA using the following command:</span></p><p><span style="color: #000000; font-family: 'courier new', courier, monospace;"><strong>sudo</strong> alsa force-reload</span></p><p><span style="color: #000000;"><img class="wp-image-5084 aligncenter" src="https://net2.com/wp-content/uploads/2020/07/word-image-9.png" width="557" height="324" srcset="https://net2.com/wp-content/uploads/2020/07/word-image-9.png 1482w, https://net2.com/wp-content/uploads/2020/07/word-image-9-300x174.png 300w, https://net2.com/wp-content/uploads/2020/07/word-image-9-1024x596.png 1024w, https://net2.com/wp-content/uploads/2020/07/word-image-9-768x447.png 768w" sizes="(max-width: 557px) 100vw, 557px" /></span></p><h2><span style="color: #000000;"><a id="post-5069-_medqyy5e73z1" style="color: #000000;"></a>Reloading Alsamixer and Pulseaudio</span></h2><p><span style="color: #000000;">In this section, you will be able to restart or reinstall Alsa and PulseAudio in case the solutions above did not help.</span></p><p><span style="color: #000000;">To do this, execute the following commands on the terminal:</span></p><table><tbody><tr><td><span style="color: #000000; font-family: 'courier new', courier, monospace;">sudo apt-get remove &#8211;purge alsa-base pulseaudio</span></p><p><span style="color: #000000;"><img class="wp-image-5085" src="https://net2.com/wp-content/uploads/2020/07/word-image-38.jpeg" srcset="https://net2.com/wp-content/uploads/2020/07/word-image-38.jpeg 1330w, https://net2.com/wp-content/uploads/2020/07/word-image-38-300x155.jpeg 300w, https://net2.com/wp-content/uploads/2020/07/word-image-38-1024x530.jpeg 1024w, https://net2.com/wp-content/uploads/2020/07/word-image-38-768x397.jpeg 768w" sizes="(max-width: 1330px) 100vw, 1330px" /></span></p><p><span style="color: #000000; font-family: 'courier new', courier, monospace;">sudo apt-get install alsa-base pulseaudio</span></p><p><span style="color: #000000;"><img class="wp-image-5086 aligncenter" src="https://net2.com/wp-content/uploads/2020/07/word-image-39.jpeg" srcset="https://net2.com/wp-content/uploads/2020/07/word-image-39.jpeg 1330w, https://net2.com/wp-content/uploads/2020/07/word-image-39-300x155.jpeg 300w, https://net2.com/wp-content/uploads/2020/07/word-image-39-1024x530.jpeg 1024w, https://net2.com/wp-content/uploads/2020/07/word-image-39-768x397.jpeg 768w" sizes="(max-width: 1330px) 100vw, 1330px" /></span></p><p><span style="color: #000000;">Finally reboot your computer and reload Alsa(see previous section) and you should be good to go.</span></p><p><span style="color: #0000ff;">Read: <a style="color: #0000ff;" href="https://net2.com/best-music-players-for-linux/" target="_blank" rel="noopener noreferrer" data-wpel-link="internal">Best music players for Linux</a></span></p><h2><span style="color: #000000;"><a id="post-5069-_ix9yzsl5vs7b" style="color: #000000;"></a>Fast dispatcher conflict</span></h2><p><span style="color: #000000;">Fast dispatcher is the feature that allows your system to convert text to speech. Sometimes it conflicts with other audio settings. If you don&#8217;t need this feature, try disabling it, as this might bring your audio back.</span></p><p><span style="color: #000000;">Open up the terminal and edit the voice dialer file using the following command:</span></p><p><span style="color: #000000; font-family: 'courier new', courier, monospace;">sudo gedit / etc / default / speech-dispatcher</span></p><p><span style="color: #000000;">Here, change RUN = yes to RUN = no. Restart your system and check if your issue has been solved.</span></td></tr></tbody></table><div class='code-block code-block-1' style='margin-bottom: 10px; padding-bottom: 14px; padding-top: 14px;'><hr /><p style="text-align: left;"><span style="color: #993300;">If you like the content, we would appreciate your support by buying us a coffe. Thank you so much for your visit and support.</span><div ><form target='_blank' action='https://www.paypal.com/cgi-bin/webscr' method='post'><input type='hidden' name='cmd' value='_donations' /><input type='hidden' name='business' value='contact@net2.com' /><input type='hidden' name='item_name' value='' /><input type='hidden' name='item_number' value='' /><input type='hidden' name='currency_code' value='USD' /><input type='hidden' name='amount' id='amount_64d559bb24841c5cd1d52d876925feff' value='' /><input type='hidden' name='no_note' value='1'><input type='hidden' name='no_shipping' value='1'><input type='hidden' name='notify_url' value='https://net2.com/wp-admin/admin-post.php?action=add_wpedon_button_ipn'><input type='hidden' name='lc' value='EN_US'><input type='hidden' name='bn' value='WPPlugin_SP'><input type='hidden' name='return' value='https://net2.com' /><input type='hidden' name='cancel_return' value='https://net2.com' /><input class='wpedon_paypalbuttonimage' type='image' src='https://www.paypal.com/en_US/i/btn/btn_donate_LG.gif' border='0' name='submit' alt='Make your payments with PayPal. It is free, secure, effective.' style='border: none;'><img alt='' border='0' style='border:none;display:none;' src='https://www.paypal.com/EN_US/i/scr/pixel.gif' width='1' height='1'></form></div></p><p>&nbsp;</p></div></div><section id="author-bio" class="clr"><div id="author-bio-inner"><div class="author-bio-avatar"> <a href="https://net2.com/author/noost/" title="Visit Author Page" rel="author" data-wpel-link="internal"> <img alt='' src='https://secure.gravatar.com/avatar/e86feeb5ac8e4a488424e6b3c6c9db61?s=100&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/e86feeb5ac8e4a488424e6b3c6c9db61?s=200&#038;d=mm&#038;r=g 2x' class='avatar avatar-100 photo' height='100' width='100' /> </a></div><div class="author-bio-content clr"><h4 class="author-bio-title"> <a href="https://net2.com/author/noost/" title="Visit Author Page" data-wpel-link="internal"> Nikolaus Oosterhof </a></h4><div class="author-bio-description clr"> Nikolaus has a degree in software development. He is passionate about gadgets with a screen, nostalgic for phones, a retired gamer and open source programmer. He likes also to write about macOS and Windows. design web pages and debug long programs!</div></div></div></section><div class="post-tags clr"> <span class="owp-tag-text">Tags: </span><a href="https://net2.com/tag/alsamixer/" rel="tag" data-wpel-link="internal">alsamixer</a><span class="owp-sep">,</span> <a href="https://net2.com/tag/pavucontrol/" rel="tag" data-wpel-link="internal">pavucontrol</a><span class="owp-sep">,</span> <a href="https://net2.com/tag/pulseaudio/" rel="tag" data-wpel-link="internal">pulseaudio</a></div><nav class="navigation post-navigation" role="navigation" aria-label="Continue Reading"><h2 class="screen-reader-text">Continue Reading</h2><div class="nav-links"><div class="nav-previous"><a href="https://net2.com/how-to-backup-and-restore-your-android-device-with-adb-on-ubuntu/" rel="prev" data-wpel-link="internal"><span class="title"><i class="fas fa-long-arrow-alt-left"></i>Previous Post</span><span class="post-title">How to backup and restore your Android device with ADB on Ubuntu</span></a></div><div class="nav-next"><a href="https://net2.com/how-to-add-guest-features-to-your-virtualbox-on-ubuntu-18-04/" rel="next" data-wpel-link="internal"><span class="title"><i class="fas fa-long-arrow-alt-right"></i>Next Post</span><span class="post-title">How to add guest features to your Virtualbox on Ubuntu 18.04</span></a></div></div></nav><section id="related-posts" class="clr"><h3 class="theme-heading related-posts-title"> <span class="text">You Might Also Like</span></h3><div class="oceanwp-row clr"><article class="related-post clr col span_1_of_3 col-1 post-5128 post type-post status-publish format-standard has-post-thumbnail hentry category-debian category-linux category-linux_mint category-ubuntu tag-pavucontrol tag-pulseaudio entry has-media"><figure class="related-post-media clr"> <a href="https://net2.com/how-manage-sounds-using-pulseaudio-on-ubuntu-18-04/" class="related-thumb" data-wpel-link="internal"> <img src="https://net2.com/wp-content/uploads/2020/07/How-to-manage-sounds-using-PulseAudio-on-Ubuntu-18-352x235.jpg" alt="How to manage sounds using PulseAudio on Ubuntu 18.04" width="352" height="235" itemprop="image" /> </a></figure><h3 class="related-post-title"> <a href="https://net2.com/how-manage-sounds-using-pulseaudio-on-ubuntu-18-04/" title="How to manage sounds using PulseAudio on Ubuntu 18.04" rel="bookmark" data-wpel-link="internal">How to manage sounds using PulseAudio on Ubuntu 18.04</a></h3> <time class="published" datetime="2020-07-20T13:07:00+02:00"><i class="icon-clock"></i>July 20, 2020</time></article></div></section><section id="comments" class="comments-area clr"><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/how-to-fix-sound-issues-on-ubuntu-18-04/#respond" style="display:none;" data-wpel-link="internal">Cancel reply</a></small></h3><form action="https://net2.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><div class="comment-textarea"><textarea name="comment" id="comment" cols="39" rows="4" tabindex="100" class="textarea-comment" placeholder="Your Comment Here..."></textarea></div><div class="comment-form-author"><input type="text" name="author" id="author" value="" placeholder="Name (required)" size="22" tabindex="101" aria-required="true" class="input-name" /></div><div class="comment-form-email"><input type="text" name="email" id="email" value="" placeholder="Email (required)" size="22" tabindex="102" aria-required="true" class="input-email" /></div><div class="comment-form-url"><input type="text" name="url" id="url" value="" placeholder="Website" size="22" tabindex="103" class="input-website" /></div><p class="form-submit"><input name="submit" type="submit" id="comment-submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='5069' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="493985d084" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="9"/></p></form></div></section></article></div></div><aside id="right-sidebar" class="sidebar-container widget-area sidebar-primary" itemscope="itemscope" itemtype="http://schema.org/WPSideBar"><div id="right-sidebar-inner" class="clr"><div id="search-2" class="sidebar-box widget_search clr"><h4 class="widget-title">Search</h4><form method="get" class="searchform" id="searchform" action="https://net2.com/"> <input type="text" class="field" name="s" id="s" placeholder="Search"> <input type="hidden" name="post_type" value="post"></form></div><div id="recent-posts-2" class="sidebar-box widget_recent_entries clr"><h4 class="widget-title">Recent Posts</h4><ul><li> <a href="https://net2.com/best-windows-10-backup-and-recovery-software/" data-wpel-link="internal">Best Windows 10 backup and recovery software</a></li><li> <a href="https://net2.com/best-messaging-apps-for-ios/" data-wpel-link="internal">Best messaging apps for iOS</a></li><li> <a href="https://net2.com/how-to-reinstall-windows-10-to-fix-problems/" data-wpel-link="internal">How to reinstall  Windows 10 to fix problems</a></li></ul></div><div id="wpp-4" class="sidebar-box popular-posts clr"><h4 class="widget-title">Most Popular posts</h4><ul class="wpp-list"><li> <a href="https://net2.com/how-to-fix-wifi-not-working-on-ubuntu/" class="wpp-post-title" target="_self" data-wpel-link="internal">How to fix WiFi not working on Ubuntu</a></li><li> <a href="https://net2.com/how-to-fix-unmet-dependencies-error-in-ubuntu/" title="How to Fix Unmet Dependencies Error on Ubuntu" class="wpp-post-title" target="_self" data-wpel-link="internal">How to Fix Unmet Dependencies Error on Ubu...</a></li><li> <a href="https://net2.com/how-to-fix-sub-process-usr-bin-dpkg-returned-an-error-code-1%e2%80%b3-error-in-ubuntu/" title="How to fix “sub process usr/bin/dpkg returned an error code 1″ Error in Ubuntu" class="wpp-post-title" target="_self" data-wpel-link="internal">How to fix “sub process usr/bin/dpkg retur...</a></li><li> <a href="https://net2.com/how-to-fix-high-memory-usage-in-linux/" class="wpp-post-title" target="_self" data-wpel-link="internal">How to fix high memory usage in Linux</a></li><li> <a href="https://net2.com/how-to-list-start-and-stop-services-at-boot-time-in-linux-ubuntu-debian/" title="How to list, start and stop services at boot time in Linux Ubuntu/Debian" class="wpp-post-title" target="_self" data-wpel-link="internal">How to list, start and stop services at bo...</a></li><li> <a href="https://net2.com/how-to-speed-up-linux/" class="wpp-post-title" target="_self" data-wpel-link="internal">How to speed up Linux</a></li><li> <a href="https://net2.com/how-to-open-system-settings-from-a-terminal-on-ubuntu-18-04/" title="How to open System Settings from the terminal in Ubuntu 18.04?" class="wpp-post-title" target="_self" data-wpel-link="internal">How to open System Settings from the termi...</a></li><li> <a href="https://net2.com/how-to-merge-or-split-pdf-files-on-linux/" class="wpp-post-title" target="_self" data-wpel-link="internal">How to merge or split PDF files on Linux</a></li><li> <a href="https://net2.com/how-to-display-files-sizes-in-mb-in-linux-ubuntu/" title="How to display files sizes in MB in Linux/Ubuntu" class="wpp-post-title" target="_self" data-wpel-link="internal">How to display files sizes in MB in Linux/...</a></li><li> <a href="https://net2.com/how-to-fix-broken-pipe-error-in-linux/" class="wpp-post-title" target="_self" data-wpel-link="internal">How to fix Broken Pipe Error in Linux</a></li><li> <a href="https://net2.com/how-to-run-applications-at-startup-on-ubuntu-18-04/" title="How to run applications at startup on Ubuntu 18.04?" class="wpp-post-title" target="_self" data-wpel-link="internal">How to run applications at startup on Ubun...</a></li></ul></div><div id="a2a_follow_widget-3" class="sidebar-box widget_a2a_follow_widget clr"><div class="a2a_kit a2a_kit_size_32 a2a_follow addtoany_list"><a class="a2a_button_facebook" href="https://www.facebook.com/aminnahdy.net2/" title="Facebook" rel="noopener nofollow noreferrer" target="_blank" data-wpel-link="external"></a><a class="a2a_button_twitter" href="https://twitter.com/Amin_net2" title="Twitter" rel="noopener nofollow noreferrer" target="_blank" data-wpel-link="external"></a><a class="a2a_button_pinterest" href="https://www.pinterest.fr/Amin_net2/" title="Pinterest" rel="noopener nofollow noreferrer" target="_blank" data-wpel-link="external"></a></div></div><div id="newsletterwidgetminimal-2" class="sidebar-box widget_newsletterwidgetminimal clr"><div class="tnp tnp-widget-minimal"><form class="tnp-form" action="https://net2.com/?na=s" method="post" onsubmit="return newsletter_check(this)"><input type="hidden" name="nr" value="widget-minimal"/><input class="tnp-email" type="email" required name="ne" value="" placeholder="Email"><input class="tnp-submit" type="submit" value="Subscribe"></form></div></div></div></aside></div></main><footer id="footer" class="site-footer" itemscope="itemscope" itemtype="http://schema.org/WPFooter"><div id="footer-inner" class="clr"><div id="footer-widgets" class="oceanwp-row clr"><div class="footer-widgets-inner container"><div class="footer-box span_1_of_4 col col-1"><div id="custom_html-2" class="widget_text footer-widget widget_custom_html clr"><div class="textwidget custom-html-widget"><a class="maxbutton-1 maxbutton maxbutton-joinnet2redditcommunity" target="_blank" rel="nofollow noopener noreferrer" href="https://reddit.com/r/net2" data-wpel-link="external"><span class='mb-text'>Join net2@Reddit</span></a></div></div></div><div class="footer-box span_1_of_4 col col-2"></div><div class="footer-box span_1_of_4 col col-3 "></div><div class="footer-box span_1_of_4 col col-4"></div></div></div><div id="footer-bottom" class="clr"><div id="footer-bottom-inner" class="container clr"><div id="footer-bottom-menu" class="navigation clr"><div class="menu-footer-container"><ul id="menu-footer" class="menu"><li id="menu-item-28" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28"><a href="https://net2.com/contact-us/" data-wpel-link="internal">Contact us</a></li><li id="menu-item-29" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29"><a href="https://net2.com/about/" data-wpel-link="internal">About</a></li><li id="menu-item-30" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-30"><a href="https://net2.com/privacy-policy/" data-wpel-link="internal">Privacy Policy</a></li></ul></div></div><div id="copyright" class="clr" role="contentinfo"> Copyright net2.com all rights reserved 2020</div></div></div></div></footer></div></div><div id="sidr-close"> <a href="#" class="toggle-sidr-close"> <i class="icon icon-close"></i><span class="close-text">Close Menu</span> </a></div><div id="mobile-nav" class="navigation clr"><ul id="menu-main_menu-1" class="mobile-menu dropdown-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-23"><a href="https://net2.com/" data-wpel-link="internal">Home</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-2460"><a href="https://net2.com/category/linux/" data-wpel-link="internal">Linux</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1236"><a href="https://net2.com/category/linux/ubuntu_tips_and_tricks/" data-wpel-link="internal">Linux Tips &#038; Tricks</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-2459"><a href="https://net2.com/category/troubleshooting/" data-wpel-link="internal">Troubleshooting</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2457"><a href="https://net2.com/category/maintenance-and-monitoring/" data-wpel-link="internal">Maintenance and monitoring</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5372"><a href="https://net2.com/category/windows/" data-wpel-link="internal">Windows</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3690"><a href="https://net2.com/category/best-software/" data-wpel-link="internal">Best Software</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2458"><a href="https://net2.com/category/installations/" data-wpel-link="internal">Installations</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3165"><a href="https://net2.com/category/computer-and-health/" data-wpel-link="internal">Computer and Health</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3044"><a href="https://net2.com/category/web_hosting/" data-wpel-link="internal">Web hosting|VPN</a></li></ul></div><div id="mobile-menu-search" class="clr"><form method="get" action="https://net2.com/" class="mobile-searchform"> <input type="search" name="s" autocomplete="off" placeholder="Search" /> <button type="submit" class="searchform-submit"> <i class="icon icon-magnifier"></i> </button> <input type="hidden" name="post_type" value="post"></form></div><div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_default_style" data-a2a-scroll-show="100" style="bottom:50px;left:0px;background-color:transparent;"><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share" data-wpel-link="external" target="_blank" rel="nofollow noopener noreferrer"></a></div><div id="wpfront-scroll-top-container"> <img src="https://net2.com/wp-content/plugins/wpfront-scroll-top/images/icons/1.png" alt="" /></div> <script type="text/javascript">function wpfront_scroll_top_init() {if(typeof wpfront_scroll_top == "function" && typeof jQuery !== "undefined") {wpfront_scroll_top({"scroll_offset":100,"button_width":0,"button_height":0,"button_opacity":0.8000000000000000444089209850062616169452667236328125,"button_fade_duration":200,"scroll_duration":400,"location":2,"marginX":20,"marginY":20,"hide_iframe":false,"auto_hide":false,"auto_hide_after":2,"button_action":"top","button_action_element_selector":"","button_action_container_selector":"html, body","button_action_element_offset":0});} else {setTimeout(wpfront_scroll_top_init, 100);}}wpfront_scroll_top_init();</script> <script type="text/javascript">(function(){
                document.addEventListener('DOMContentLoaded', function(){
                    let wpp_widgets = document.querySelectorAll('.popular-posts-sr');

                    if ( wpp_widgets ) {
                        for (let i = 0; i < wpp_widgets.length; i++) {
                            let wpp_widget = wpp_widgets[i];
                            WordPressPopularPosts.theme(wpp_widget);
                        }
                    }
                });
            })();</script> <script>var WPPImageObserver = null;

            function wpp_load_img(img) {
                if ( ! 'imgSrc' in img.dataset || ! img.dataset.imgSrc )
                    return;

                img.src = img.dataset.imgSrc;

                if ( 'imgSrcset' in img.dataset ) {
                    img.srcset = img.dataset.imgSrcset;
                    img.removeAttribute('data-img-srcset');
                }

                img.classList.remove('wpp-lazyload');
                img.removeAttribute('data-img-src');
                img.classList.add('wpp-lazyloaded');
            }

            function wpp_observe_imgs(){
                let wpp_images = document.querySelectorAll('img.wpp-lazyload'),
                    wpp_widgets = document.querySelectorAll('.popular-posts-sr');

                if ( wpp_images.length || wpp_widgets.length ) {
                    if ( 'IntersectionObserver' in window ) {
                        WPPImageObserver = new IntersectionObserver(function(entries, observer) {
                            entries.forEach(function(entry) {
                                if (entry.isIntersecting) {
                                    let img = entry.target;
                                    wpp_load_img(img);
                                    WPPImageObserver.unobserve(img);
                                }
                            });
                        });

                        if ( wpp_images.length ) {
                            wpp_images.forEach(function(image) {
                                WPPImageObserver.observe(image);
                            });
                        }

                        if ( wpp_widgets.length ) {
                            for (var i = 0; i < wpp_widgets.length; i++) {
                                let wpp_widget_images = wpp_widgets[i].querySelectorAll('img.wpp-lazyload');

                                if ( ! wpp_widget_images.length && wpp_widgets[i].shadowRoot ) {
                                    wpp_widget_images = wpp_widgets[i].shadowRoot.querySelectorAll('img.wpp-lazyload');
                                }

                                if ( wpp_widget_images.length ) {
                                    wpp_widget_images.forEach(function(image) {
                                        WPPImageObserver.observe(image);
                                    });
                                }
                            }
                        }
                    } /** Fallback for older browsers */
                    else {
                        if ( wpp_images.length ) {
                            for (var i = 0; i < wpp_images.length; i++) {
                                wpp_load_img(wpp_images[i]);
                                wpp_images[i].classList.remove('wpp-lazyloaded');
                            }
                        }

                        if ( wpp_widgets.length ) {
                            for (var j = 0; j < wpp_widgets.length; j++) {
                                let wpp_widget = wpp_widgets[j],
                                    wpp_widget_images = wpp_widget.querySelectorAll('img.wpp-lazyload');

                                if ( ! wpp_widget_images.length && wpp_widget.shadowRoot ) {
                                    wpp_widget_images = wpp_widget.shadowRoot.querySelectorAll('img.wpp-lazyload');
                                }

                                if ( wpp_widget_images.length ) {
                                    for (var k = 0; k < wpp_widget_images.length; k++) {
                                        wpp_load_img(wpp_widget_images[k]);
                                        wpp_widget_images[k].classList.remove('wpp-lazyloaded');
                                    }
                                }
                            }
                        }
                    }
                }
            }

            document.addEventListener('DOMContentLoaded', function() {
                wpp_observe_imgs();

                // When an ajaxified WPP widget loads,
                // Lazy load its images
                document.addEventListener('wpp-onload', function(){
                    wpp_observe_imgs();
                });
            });</script> <script type='text/javascript'>var wpcf7 = {"apiSettings":{"root":"https:\/\/net2.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};</script> <script type='text/javascript' src='https://net2.com/wp-content/cache/autoptimize/js/autoptimize_single_309e1a27ab5c8722dea8f46fc8c384d5.js?ver=5.2'></script> <script type='text/javascript' src='https://net2.com/wp-content/plugins/wpfront-scroll-top/js/wpfront-scroll-top.min.js?ver=2.0.2'></script> <script type='text/javascript' src='https://net2.com/wp-includes/js/comment-reply.min.js?ver=5.3.4'></script> <script type='text/javascript' src='https://net2.com/wp-includes/js/imagesloaded.min.js?ver=3.2.0'></script> <script type='text/javascript'>var q2w3_sidebar_options = [{"sidebar":"sidebar","margin_top":20,"margin_bottom":0,"stop_id":"footer","screen_max_width":0,"screen_max_height":0,"width_inherit":false,"refresh_interval":1500,"window_load_hook":false,"disable_mo_api":false,"widgets":["wpp-4","a2a_follow_widget-3","newsletterwidgetminimal-2"]}];</script> <script type='text/javascript' src='https://net2.com/wp-content/plugins/q2w3-fixed-widget/js/q2w3-fixed-widget.min.js?ver=5.1.9'></script> <script type='text/javascript'>var newsletter = {"messages":{"email_error":"Email address is not correct","name_error":"Name is required","surname_error":"Last name is required","profile_error":"A mandatory field is not filled in","privacy_error":"You must accept the privacy policy"},"profile_max":"20"};</script> <script type='text/javascript' src='https://net2.com/wp-content/cache/autoptimize/js/autoptimize_single_b562667fe2faa8b03924bed00a98d7ec.js?ver=6.7.3'></script> <script type='text/javascript'>var oceanwpLocalize = {"isRTL":"","menuSearchStyle":"drop_down","sidrSource":"#sidr-close, #mobile-nav, #mobile-menu-search","sidrDisplace":"1","sidrSide":"left","sidrDropdownTarget":"icon","verticalHeaderTarget":"icon","customSelects":".woocommerce-ordering .orderby, #dropdown_product_cat, .widget_categories select, .widget_archive select, .single-product .variations_form .variations select","ajax_url":"https:\/\/net2.com\/wp-admin\/admin-ajax.php"};</script> <script type='text/javascript' src='https://net2.com/wp-content/cache/autoptimize/js/autoptimize_single_4764ccf1821b5441e9e41f3ba9106801.js?ver=1.7.4'></script> <script type='text/javascript' src='https://net2.com/wp-includes/js/wp-embed.min.js?ver=5.3.4'></script> <!--[if lt IE 9]> <script type='text/javascript' src='https://net2.com/wp-content/themes/oceanwp/assets/js//third/html5.min.js?ver=1.7.4'></script> <![endif]--> <script type='text/javascript' src='https://cdn.onesignal.com/sdks/OneSignalSDK.js?ver=5.3.4' async='async'></script> <script async="async" type='text/javascript' src='https://net2.com/wp-content/cache/autoptimize/js/autoptimize_single_270f0cd7341bce6c2afacf2682e7690e.js?ver=4.1.6'></script> <script type="text/javascript" id="uagb-script-frontend">document.addEventListener("DOMContentLoaded", function(){( function( $ ) {  })(jQuery)})</script> <script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('edmonton.php', '/detroitchicago/edmonton.webp?a=a&cb=0&shcb=34', true, ['/detroitchicago/minneapolis.js'], true, false, false, false);
__ez.queue.addFile('jellyfish.php', '/porpoiseant/jellyfish.webp?a=a&cb=0&shcb=34', false, [], true, false, false, false);
</script>

<script>var _audins_dom="net2_com",_audins_did=190025;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=191-0");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.net2_com,DomainId.190025" border="0" height="1" width="1" alt="Quantcast"/></div></noscript><noscript><img src="https://sb.scorecardresearch.com/p?c1=2&c2=20015427&cv=2.0&cj=1"/></noscript>
<script type='text/javascript' data-cfasync='false'></script></body></html>