<!DOCTYPE html><html class="html" lang="en-US" prefix="og: http://ogp.me/ns#" itemscope itemtype="http://schema.org/WebPage"><head><meta charset="UTF-8"><link rel="profile" href="http://gmpg.org/xfn/11"><!-- <link type="text/css" media="all" href="https://net2.com/wp-content/cache/autoptimize/autoptimize_4b5fdc7e0fe9408a28cb0d698cc55095.php" rel="stylesheet" /> -->
<link rel="stylesheet" type="text/css" href="//net2.com/wp-content/cache/wpfc-minified/7zp5ix78/5tf17.css" media="all"/><title>How to find the largest files on Linux ?</title><link rel="pingback" href="https://net2.com/xmlrpc.php"><meta name="viewport" content="width=device-width, initial-scale=1"><meta name="description" content="Most of us have installed tens of applications in our machines. As time goes on, many files will get bigger and bigger and your disk space will start to"/><link rel="canonical" href="https://net2.com/how-to-find-the-largest-files-on-linux/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="How to find the largest files on Linux ?" /><meta property="og:description" content="Most of us have installed tens of applications in our machines. As time goes on, many files will get bigger and bigger and your disk space will start to" /><meta property="og:url" content="https://net2.com/how-to-find-the-largest-files-on-linux/" /><meta property="og:site_name" content="net2" /><meta property="article:tag" content="baobab" /><meta property="article:tag" content="command du" /><meta property="article:tag" content="command find" /><meta property="article:tag" content="command ls" /><meta property="article:tag" content="ubuntu largest files" /><meta property="article:section" content="Linux" /><meta property="article:published_time" content="2019-08-01T18:46:40+00:00" /><meta property="article:modified_time" content="2019-08-28T10:57:29+00:00" /><meta property="og:updated_time" content="2019-08-28T10:57:29+00:00" /><meta property="og:image" content="https://net2.com/wp-content/uploads/2019/08/find-largest-files-compressor.jpg" /><meta property="og:image:secure_url" content="https://net2.com/wp-content/uploads/2019/08/find-largest-files-compressor.jpg" /><meta property="og:image:width" content="360" /><meta property="og:image:height" content="204" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:description" content="Most of us have installed tens of applications in our machines. As time goes on, many files will get bigger and bigger and your disk space will start to" /><meta name="twitter:title" content="How to find the largest files on Linux ?" /><meta name="twitter:image" content="https://net2.com/wp-content/uploads/2019/08/find-largest-files-compressor.jpg" /> <script type='application/ld+json'>{"@context":"https:\/\/schema.org","@type":"Organization","url":"https:\/\/net2.com\/","sameAs":[],"@id":"https:\/\/net2.com\/#organization","name":"net2","logo":"https:\/\/net2.com\/wp-content\/uploads\/2019\/08\/LOGO-net2.png"}</script> <link rel='dns-prefetch' href='//www.google.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="net2 &raquo; Feed" href="https://net2.com/feed/" /><link rel="alternate" type="application/rss+xml" title="net2 &raquo; Comments Feed" href="https://net2.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="net2 &raquo; How to find the largest files on Linux ? Comments Feed" href="https://net2.com/how-to-find-the-largest-files-on-linux/feed/" />  <script type="text/javascript" data-cfasync="false">var mi_version         = '7.9.0';
var mi_track_user      = true;
var mi_no_track_reason = '';
var disableStr = 'ga-disable-UA-146071783-1';
/* Function to detect opted out users */
function __gaTrackerIsOptedOut() {
return document.cookie.indexOf(disableStr + '=true') > -1;
}
/* Disable tracking if the opt-out cookie exists. */
if ( __gaTrackerIsOptedOut() ) {
window[disableStr] = true;
}
/* Opt-out function */
function __gaTrackerOptout() {
document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
window[disableStr] = true;
}
if ( mi_track_user ) {
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');
__gaTracker('create', 'UA-146071783-1', 'auto');
__gaTracker('set', 'forceSSL', true);
__gaTracker('require', 'displayfeatures');
__gaTracker('send','pageview');
} else {
console.log( "" );
(function() {
/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
var noopfn = function() {
return null;
};
var noopnullfn = function() {
return null;
};
var Tracker = function() {
return null;
};
var p = Tracker.prototype;
p.get = noopfn;
p.set = noopfn;
p.send = noopfn;
var __gaTracker = function() {
var len = arguments.length;
if ( len === 0 ) {
return;
}
var f = arguments[len-1];
if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
return;
}
try {
f.hitCallback();
} catch (ex) {
}
};
__gaTracker.create = function() {
return new Tracker();
};
__gaTracker.getByName = noopnullfn;
__gaTracker.getAll = function() {
return [];
};
__gaTracker.remove = noopfn;
window['__gaTracker'] = __gaTracker;
})();
}</script>  <script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/net2.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.2.3"}};
!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);</script> <script type='text/javascript'>var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,exe,js,pdf,ppt,tgz,zip,xls","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"}]","home_url":"https:\/\/net2.com","hash_tracking":"false"};</script> <script src='//net2.com/wp-content/cache/wpfc-minified/8wifd632/5teou.js' type="text/javascript"></script>
<!-- <script type='text/javascript' src='https://net2.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend.min.js?ver=7.9.0'></script> --> <!-- <script type='text/javascript' src='https://net2.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script> --> <!-- <script type='text/javascript' src='https://net2.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script> --> <script type='text/javascript'>var wpp_params = {"sampling_active":"0","sampling_rate":"100","ajax_url":"https:\/\/net2.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts\/","ID":"145","token":"3b9ecbcf76","debug":""};</script> <script src='//net2.com/wp-content/cache/wpfc-minified/d3r1ay2k/5teou.js' type="text/javascript"></script>
<!-- <script type='text/javascript' src='https://net2.com/wp-content/plugins/wordpress-popular-posts/public/js/wpp-4.2.0.min.js?ver=4.2.2'></script> --> <link rel='https://api.w.org/' href='https://net2.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://net2.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://net2.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.2.3" /><link rel='shortlink' href='https://net2.com/?p=145' /><link rel="alternate" type="application/json+oembed" href="https://net2.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnet2.com%2Fhow-to-find-the-largest-files-on-linux%2F" /><link rel="alternate" type="text/xml+oembed" href="https://net2.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnet2.com%2Fhow-to-find-the-largest-files-on-linux%2F&#038;format=xml" /><link rel="icon" href="https://net2.com/wp-content/uploads/2019/08/LOGO-ICON-net2.png" sizes="32x32" /><link rel="icon" href="https://net2.com/wp-content/uploads/2019/08/LOGO-ICON-net2.png" sizes="192x192" /><link rel="apple-touch-icon-precomposed" href="https://net2.com/wp-content/uploads/2019/08/LOGO-ICON-net2.png" /><meta name="msapplication-TileImage" content="https://net2.com/wp-content/uploads/2019/08/LOGO-ICON-net2.png" /></head><body class="post-template-default single single-post postid-145 single-format-standard wp-custom-logo wp-embed-responsive oceanwp-theme sidebar-mobile default-breakpoint has-sidebar content-right-sidebar post-in-category-linux post-in-category-ubuntu page-header-disabled"><div id="outer-wrap" class="site clr"><div id="wrap" class="clr"><header id="site-header" class="minimal-header clr" data-height="74" itemscope="itemscope" itemtype="http://schema.org/WPHeader"><div id="site-header-inner" class="clr container"><div id="site-logo" class="clr" itemscope itemtype="http://schema.org/Brand"><div id="site-logo-inner" class="clr"> <a href="https://net2.com/" class="custom-logo-link" rel="home"><noscript><img width="153" height="89" src="https://net2.com/wp-content/uploads/2019/08/cropped-LOGO-net2.png" class="custom-logo" alt="net2" srcset="https://net2.com/wp-content/uploads/2019/08/cropped-LOGO-net2.png 1x, https://net2.com/wp-content/uploads/2019/08/LOGO-RETINA-net2.png 2x" /></noscript><img width="153" height="89" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20153%2089%22%3E%3C/svg%3E' data-src="https://net2.com/wp-content/uploads/2019/08/cropped-LOGO-net2.png" class="lazyload custom-logo" alt="net2" data-srcset="https://net2.com/wp-content/uploads/2019/08/cropped-LOGO-net2.png 1x, https://net2.com/wp-content/uploads/2019/08/LOGO-RETINA-net2.png 2x" /></a></div></div><div id="site-navigation-wrap" class="clr"><nav id="site-navigation" class="navigation main-navigation clr" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement"><ul id="menu-main_menu" class="main-menu dropdown-menu sf-menu"><li id="menu-item-23" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-23"><a href="https://net2.com/" class="menu-link"><span class="text-wrap">Home</span></a></li><li id="menu-item-805" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-805"><a href="https://net2.com/category/linux/ubuntu/" class="menu-link"><span class="text-wrap">Ubuntu</span></a></li><li id="menu-item-1236" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1236"><a href="https://net2.com/category/linux/ubuntu_tips_and_tricks/" class="menu-link"><span class="text-wrap">Ubuntu Tips &#038; Tricks</span></a></li><li class="search-toggle-li"><a href="#" class="site-search-toggle search-dropdown-toggle"><span class="icon-magnifier"></span></a></li></ul><div id="searchform-dropdown" class="header-searchform-wrap clr"><form method="get" class="searchform" id="searchform" action="https://net2.com/"> <input type="text" class="field" name="s" id="s" placeholder="Search"> <input type="hidden" name="post_type" value="post"></form></div></nav></div><div class="oceanwp-mobile-menu-icon clr mobile-right"> <a href="#" class="mobile-menu"> <i class="fa fa-bars"></i> <span class="oceanwp-text">Menu</span> </a></div></div></header><main id="main" class="site-main clr" ><div id="content-wrap" class="container clr"><div id="primary" class="content-area clr"><div id="content" class="site-content clr"><div class='code-block code-block-2' style='margin: 8px auto; text-align: center; display: block; clear: both;'> <script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle"
style="display:block"
data-ad-client="ca-pub-4222719099368092"
data-ad-slot="6293402886"
data-ad-format="auto"
data-full-width-responsive="true"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div><article id="post-145"><header class="entry-header clr"><h2 class="single-post-title entry-title" itemprop="headline">How to find the largest files on Linux ?</h2></header><ul class="meta clr"><li class="meta-author" itemprop="name"><i class="icon-user"></i><a href="https://net2.com/author/aminn2000/" title="Posts by amin nahdy" rel="author"  itemprop="author" itemscope="itemscope" itemtype="http://schema.org/Person">amin nahdy</a></li><li class="meta-date" itemprop="datePublished"><i class="icon-clock"></i>August 1, 2019</li><li class="meta-cat"><i class="icon-folder"></i><a href="https://net2.com/category/linux/" rel="category tag">Linux</a> <span class="owp-sep">/</span> <a href="https://net2.com/category/linux/ubuntu/" rel="category tag">Ubuntu</a></li><li class="meta-comments"><i class="icon-bubble"></i><a href="https://net2.com/how-to-find-the-largest-files-on-linux/#respond" class="comments-link local" >0 Comments</a></li></ul><div class="entry-content clr" itemprop="text"><p>Most of us have installed tens of applications in our machines. As time goes on, many files will get bigger and bigger and your disk space will start to shrink. It is therefore important to know the files or directories that are eating up your machine disk space.The good news is that you can very easily find out the files with the biggest sizes in a particular directory in your Ubuntu &amp; sld (similar linux distros). In this article, you will learn different methods to find out the largest files in your system :</p><h2><a id="post-145-_a4py6gjptad6"></a>Command 1 :<strong> Find </strong></h2><p>The find command will start searching in the directory that you specify and then will proceed to all accessible subdirectories. More than one starting directory can be specified for search. The command below will help us look for large files .</p><p>First open up your terminal and type in the command :</p><p><span style="font-family: 'courier new', courier, monospace;">sudo-i</span></p><p><noscript><img class="wp-image-146 aligncenter" src="https://net2.com/wp-content/uploads/2019/08/word-image-41.png" srcset="https://net2.com/wp-content/uploads/2019/08/word-image-41.png 734w, https://net2.com/wp-content/uploads/2019/08/word-image-41-300x35.png 300w" sizes="(max-width: 734px) 100vw, 734px" /></noscript><img class="lazyload wp-image-146 aligncenter" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20%20%22%3E%3C/svg%3E' data-src="https://net2.com/wp-content/uploads/2019/08/word-image-41.png" data-srcset="https://net2.com/wp-content/uploads/2019/08/word-image-41.png 734w, https://net2.com/wp-content/uploads/2019/08/word-image-41-300x35.png 300w" data-sizes="(max-width: 734px) 100vw, 734px" /></p><p>Next, issue the commands below to see the largest files while skipping the directories on the computer type this :</p><p><span style="font-family: 'courier new', courier, monospace;">sudo find / -type f -printf &#8220;%s\t%p\n&#8221; | sort -n | tail -1</span></p><p><noscript><img class="aligncenter wp-image-1010 size-full" src="https://net2.com/wp-content/uploads/2019/08/sudo-find-compressor-1.jpg" alt="sudo command with find" width="1340" height="542" srcset="https://net2.com/wp-content/uploads/2019/08/sudo-find-compressor-1.jpg 1340w, https://net2.com/wp-content/uploads/2019/08/sudo-find-compressor-1-300x121.jpg 300w, https://net2.com/wp-content/uploads/2019/08/sudo-find-compressor-1-768x311.jpg 768w, https://net2.com/wp-content/uploads/2019/08/sudo-find-compressor-1-1024x414.jpg 1024w" sizes="(max-width: 1340px) 100vw, 1340px" /></noscript><img class="lazyload aligncenter wp-image-1010 size-full" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%201340%20542%22%3E%3C/svg%3E' data-src="https://net2.com/wp-content/uploads/2019/08/sudo-find-compressor-1.jpg" alt="sudo command with find" width="1340" height="542" data-srcset="https://net2.com/wp-content/uploads/2019/08/sudo-find-compressor-1.jpg 1340w, https://net2.com/wp-content/uploads/2019/08/sudo-find-compressor-1-300x121.jpg 300w, https://net2.com/wp-content/uploads/2019/08/sudo-find-compressor-1-768x311.jpg 768w, https://net2.com/wp-content/uploads/2019/08/sudo-find-compressor-1-1024x414.jpg 1024w" data-sizes="(max-width: 1340px) 100vw, 1340px" /></p><p><span style="font-family: 'courier new', courier, monospace;">$ find $HOME -type f -printf &#8216;%s %p\n&#8217; | sort -nr | head -10</span></p><p><noscript><img class="wp-image-148 aligncenter" src="https://net2.com/wp-content/uploads/2019/08/word-image-43.png" srcset="https://net2.com/wp-content/uploads/2019/08/word-image-43.png 1342w, https://net2.com/wp-content/uploads/2019/08/word-image-43-300x57.png 300w, https://net2.com/wp-content/uploads/2019/08/word-image-43-768x147.png 768w, https://net2.com/wp-content/uploads/2019/08/word-image-43-1024x195.png 1024w" sizes="(max-width: 1342px) 100vw, 1342px" /></noscript><img class="lazyload wp-image-148 aligncenter" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20%20%22%3E%3C/svg%3E' data-src="https://net2.com/wp-content/uploads/2019/08/word-image-43.png" data-srcset="https://net2.com/wp-content/uploads/2019/08/word-image-43.png 1342w, https://net2.com/wp-content/uploads/2019/08/word-image-43-300x57.png 300w, https://net2.com/wp-content/uploads/2019/08/word-image-43-768x147.png 768w, https://net2.com/wp-content/uploads/2019/08/word-image-43-1024x195.png 1024w" data-sizes="(max-width: 1342px) 100vw, 1342px" /></p><p>There are further options you can use in order to find large files: the -size option. The next command for instance will display all files that are larger than 100MiB (this is not 100MB, see <a href="https://askubuntu.com/q/22102/6969">here</a> if you are confused):</p><p><span style="font-family: 'courier new', courier, monospace;">find / -size +100M -ls</span></p><p><noscript><img class="wp-image-1011 size-full aligncenter" src="https://net2.com/wp-content/uploads/2019/08/sudo-find-with-size-compressor.jpg" alt="command sudo find with size" width="1340" height="416" srcset="https://net2.com/wp-content/uploads/2019/08/sudo-find-with-size-compressor.jpg 1340w, https://net2.com/wp-content/uploads/2019/08/sudo-find-with-size-compressor-300x93.jpg 300w, https://net2.com/wp-content/uploads/2019/08/sudo-find-with-size-compressor-768x238.jpg 768w, https://net2.com/wp-content/uploads/2019/08/sudo-find-with-size-compressor-1024x318.jpg 1024w" sizes="(max-width: 1340px) 100vw, 1340px" /></noscript><img class="lazyload wp-image-1011 size-full aligncenter" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%201340%20416%22%3E%3C/svg%3E' data-src="https://net2.com/wp-content/uploads/2019/08/sudo-find-with-size-compressor.jpg" alt="command sudo find with size" width="1340" height="416" data-srcset="https://net2.com/wp-content/uploads/2019/08/sudo-find-with-size-compressor.jpg 1340w, https://net2.com/wp-content/uploads/2019/08/sudo-find-with-size-compressor-300x93.jpg 300w, https://net2.com/wp-content/uploads/2019/08/sudo-find-with-size-compressor-768x238.jpg 768w, https://net2.com/wp-content/uploads/2019/08/sudo-find-with-size-compressor-1024x318.jpg 1024w" data-sizes="(max-width: 1340px) 100vw, 1340px" /></p><p>If however you want to add a range of min and max sizes, you can just proceed as the following command which will find files between 100MiB and 200MiB:</p><p><span style="font-family: 'courier new', courier, monospace;">find / -size +100M -size -200M -ls</span></p><p>This seems like the perfect application for find:</p><p>Finally the following command might also be very relevant here :</p><p><span style="font-family: 'courier new', courier, monospace;">find $DIRECTORY -type f -exec ls -s {} \; | sort -n | tail -n 5</span></p><p>This will find all files in the folder $DIRECTORY which undergo ls -s. The result is then sorted numerically via the sort command and finally, the last five entries are displayed.<br /> To summarize, the command above will then display the largest 5 files in the folder $DIRETORY.</p><p>As a final word about the find command, you can for instance look for files which are more recent : less or equal than n days (-ctime -n) or which belong to specific users (-user mrlinus).</p><h2><a id="post-145-_c7xtmc3269or"></a>Command 2 : <strong>du</strong></h2><p>The <strong>du </strong>command which stands for disk usage estimates file space usage. It can actually be used to fetch the files and folders which are eating up excessive amounts of space on your hard disk .</p><p>First type in the command below in order to switch to root :</p><p><span style="font-family: 'courier new', courier, monospace;">sudo-i</span></p><p>And then issue the command below :</p><p><span style="font-family: 'courier new', courier, monospace;">sudo du -a /home | sort -n -r | head -n 20</span></p><p><noscript><img class="wp-image-1013 size-full aligncenter" src="https://net2.com/wp-content/uploads/2019/08/sudo-du-with-sort-and-head-compressor.jpg" alt="sudo du with sort and head" width="1344" height="846" srcset="https://net2.com/wp-content/uploads/2019/08/sudo-du-with-sort-and-head-compressor.jpg 1344w, https://net2.com/wp-content/uploads/2019/08/sudo-du-with-sort-and-head-compressor-300x189.jpg 300w, https://net2.com/wp-content/uploads/2019/08/sudo-du-with-sort-and-head-compressor-768x483.jpg 768w, https://net2.com/wp-content/uploads/2019/08/sudo-du-with-sort-and-head-compressor-1024x645.jpg 1024w" sizes="(max-width: 1344px) 100vw, 1344px" /></noscript><img class="lazyload wp-image-1013 size-full aligncenter" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%201344%20846%22%3E%3C/svg%3E' data-src="https://net2.com/wp-content/uploads/2019/08/sudo-du-with-sort-and-head-compressor.jpg" alt="sudo du with sort and head" width="1344" height="846" data-srcset="https://net2.com/wp-content/uploads/2019/08/sudo-du-with-sort-and-head-compressor.jpg 1344w, https://net2.com/wp-content/uploads/2019/08/sudo-du-with-sort-and-head-compressor-300x189.jpg 300w, https://net2.com/wp-content/uploads/2019/08/sudo-du-with-sort-and-head-compressor-768x483.jpg 768w, https://net2.com/wp-content/uploads/2019/08/sudo-du-with-sort-and-head-compressor-1024x645.jpg 1024w" data-sizes="(max-width: 1344px) 100vw, 1344px" /></p><p>du calculates the files sizes in the home directory which will then go through a “sort” operation and finally the output will be limited thanks to the “head” argument which considers only the top 20 largest files.</p><p>In order to display the directories with the biggest sizes in the current working folder, just run:</p><p><span style="font-family: 'courier new', courier, monospace;">sudo du -a | sort -n -r | head -n 10</span></p><p><noscript><img class="aligncenter wp-image-1015 size-large" src="https://net2.com/wp-content/uploads/2019/08/sudo-du-with-sort-and-head-2-compressor-1024x315.jpg" alt="sudo du -a | sort -n -r | head -n 10" width="1024" height="315" srcset="https://net2.com/wp-content/uploads/2019/08/sudo-du-with-sort-and-head-2-compressor-1024x315.jpg 1024w, https://net2.com/wp-content/uploads/2019/08/sudo-du-with-sort-and-head-2-compressor-300x92.jpg 300w, https://net2.com/wp-content/uploads/2019/08/sudo-du-with-sort-and-head-2-compressor-768x237.jpg 768w, https://net2.com/wp-content/uploads/2019/08/sudo-du-with-sort-and-head-2-compressor.jpg 1344w" sizes="(max-width: 1024px) 100vw, 1024px" /></noscript><img class="lazyload aligncenter wp-image-1015 size-large" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%201024%20315%22%3E%3C/svg%3E' data-src="https://net2.com/wp-content/uploads/2019/08/sudo-du-with-sort-and-head-2-compressor-1024x315.jpg" alt="sudo du -a | sort -n -r | head -n 10" width="1024" height="315" data-srcset="https://net2.com/wp-content/uploads/2019/08/sudo-du-with-sort-and-head-2-compressor-1024x315.jpg 1024w, https://net2.com/wp-content/uploads/2019/08/sudo-du-with-sort-and-head-2-compressor-300x92.jpg 300w, https://net2.com/wp-content/uploads/2019/08/sudo-du-with-sort-and-head-2-compressor-768x237.jpg 768w, https://net2.com/wp-content/uploads/2019/08/sudo-du-with-sort-and-head-2-compressor.jpg 1344w" data-sizes="(max-width: 1024px) 100vw, 1024px" /></p><p>Here is an explanation of the command above :</p><p>du command: calculates the file space usage.</p><p>a : shows all files and directories.</p><p>sort command : Sorts the input stream of text files (from the entry of the pipe).</p><p>-n : &#8211;numeric-sort : string numerical value comparison.</p><p>-r : &#8211;reverse : the result of comparisons is reversed.</p><p>head : Reads the provided list and prepares it for standard output.</p><div class='code-block code-block-1' style='margin-bottom: 10px;'> <script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle"
style="display:block; text-align:center;"
data-ad-layout="in-article"
data-ad-format="fluid"
data-ad-client="ca-pub-4222719099368092"
data-ad-slot="7786447957"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div><p>-n : tells head to how many lines to return. (In our case, we limited the display to the first 10 lines).</p><p>If you want to use KB, GB , just issue the command as follows :</p><p><span style="font-family: 'courier new', courier, monospace;">du -hs * | sort -rh | head -n 10</span></p><p><noscript><img class="aligncenter wp-image-1016 size-full" src="https://net2.com/wp-content/uploads/2019/08/du-hs-sort-rh-head-5-compressor.jpg" alt="du -hs * | sort -rh | head -5" width="1344" height="452" srcset="https://net2.com/wp-content/uploads/2019/08/du-hs-sort-rh-head-5-compressor.jpg 1344w, https://net2.com/wp-content/uploads/2019/08/du-hs-sort-rh-head-5-compressor-300x101.jpg 300w, https://net2.com/wp-content/uploads/2019/08/du-hs-sort-rh-head-5-compressor-768x258.jpg 768w, https://net2.com/wp-content/uploads/2019/08/du-hs-sort-rh-head-5-compressor-1024x344.jpg 1024w" sizes="(max-width: 1344px) 100vw, 1344px" /></noscript><img class="lazyload aligncenter wp-image-1016 size-full" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%201344%20452%22%3E%3C/svg%3E' data-src="https://net2.com/wp-content/uploads/2019/08/du-hs-sort-rh-head-5-compressor.jpg" alt="du -hs * | sort -rh | head -5" width="1344" height="452" data-srcset="https://net2.com/wp-content/uploads/2019/08/du-hs-sort-rh-head-5-compressor.jpg 1344w, https://net2.com/wp-content/uploads/2019/08/du-hs-sort-rh-head-5-compressor-300x101.jpg 300w, https://net2.com/wp-content/uploads/2019/08/du-hs-sort-rh-head-5-compressor-768x258.jpg 768w, https://net2.com/wp-content/uploads/2019/08/du-hs-sort-rh-head-5-compressor-1024x344.jpg 1024w" data-sizes="(max-width: 1344px) 100vw, 1344px" /></p><p>The above command will show the largest directories which are consuming excessive disk space. You can go ahead and delete them if you think they are useless in order to free up some space.</p><p>In order now to display the largest directories/files including sub-folders, run :</p><p><span style="font-family: 'courier new', courier, monospace;">du -Sh | sort -rh | head -n 10</span></p><p><noscript><img class="aligncenter wp-image-1017 size-full" src="https://net2.com/wp-content/uploads/2019/08/du-hs-sort-rh-head-n-10-compressor.jpg" alt="du -Sh | sort -rh | head -n 10" width="1344" height="418" srcset="https://net2.com/wp-content/uploads/2019/08/du-hs-sort-rh-head-n-10-compressor.jpg 1344w, https://net2.com/wp-content/uploads/2019/08/du-hs-sort-rh-head-n-10-compressor-300x93.jpg 300w, https://net2.com/wp-content/uploads/2019/08/du-hs-sort-rh-head-n-10-compressor-768x239.jpg 768w, https://net2.com/wp-content/uploads/2019/08/du-hs-sort-rh-head-n-10-compressor-1024x318.jpg 1024w" sizes="(max-width: 1344px) 100vw, 1344px" /></noscript><img class="lazyload aligncenter wp-image-1017 size-full" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%201344%20418%22%3E%3C/svg%3E' data-src="https://net2.com/wp-content/uploads/2019/08/du-hs-sort-rh-head-n-10-compressor.jpg" alt="du -Sh | sort -rh | head -n 10" width="1344" height="418" data-srcset="https://net2.com/wp-content/uploads/2019/08/du-hs-sort-rh-head-n-10-compressor.jpg 1344w, https://net2.com/wp-content/uploads/2019/08/du-hs-sort-rh-head-n-10-compressor-300x93.jpg 300w, https://net2.com/wp-content/uploads/2019/08/du-hs-sort-rh-head-n-10-compressor-768x239.jpg 768w, https://net2.com/wp-content/uploads/2019/08/du-hs-sort-rh-head-n-10-compressor-1024x318.jpg 1024w" data-sizes="(max-width: 1344px) 100vw, 1344px" /></p><p>Here is a breakdown of the command above:</p><p>du: The du command</p><p>-h : The sizes will be shown in human readable format (.e.g. 3MB).</p><p>-S : The subdirectories size will not be included.</p><p>Sort : Sorts the input stream of text files (from the entry of the pipe).</p><p>-r : &#8211;reverse : the result of comparisons is reversed.</p><p>-h : human readable formatted numbers comparison enabled (e.g., 2K, 1G).</p><p>head : Reads the provided list and prepares it for standard output.</p><p>-n : tells head to how many lines to return. (In our case, we limited the display to the first 10 lines).</p><p>If you want to exclude for example error message of type &#8220;permission denied&#8221; , simply add teh parameter : 2&gt;/dev/null like for instance:</p><p><span style="font-family: 'courier new', courier, monospace;">du -a /* 2&gt;/dev/null | sort -nr | head -n 50</span></p><p>In order to find all files with the size in the GB range for instance, you could use both du command and grep command :</p><p><span style="font-family: 'courier new', courier, monospace;">du -h -a /dir | grep &#8220;[0-9]G\b&#8221;</span></p><h2><a id="post-145-_96sbf7stao6y"></a>Command 3 :<strong> ls </strong></h2><p>The ls command is used to display information about directories and files.</p><p>So, to list the 5 top largest files in the /bin directory , issue the command below :</p><p>ls -lSh /bin | head -5</p><p><noscript><img class="wp-image-154" src="https://net2.com/wp-content/uploads/2019/08/word-image-49.png" srcset="https://net2.com/wp-content/uploads/2019/08/word-image-49.png 1342w, https://net2.com/wp-content/uploads/2019/08/word-image-49-300x55.png 300w, https://net2.com/wp-content/uploads/2019/08/word-image-49-768x141.png 768w, https://net2.com/wp-content/uploads/2019/08/word-image-49-1024x188.png 1024w" sizes="(max-width: 1342px) 100vw, 1342px" /></noscript><img class="lazyload wp-image-154" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20%20%22%3E%3C/svg%3E' data-src="https://net2.com/wp-content/uploads/2019/08/word-image-49.png" data-srcset="https://net2.com/wp-content/uploads/2019/08/word-image-49.png 1342w, https://net2.com/wp-content/uploads/2019/08/word-image-49-300x55.png 300w, https://net2.com/wp-content/uploads/2019/08/word-image-49-768x141.png 768w, https://net2.com/wp-content/uploads/2019/08/word-image-49-1024x188.png 1024w" data-sizes="(max-width: 1342px) 100vw, 1342px" /></p><p><strong><span style="font-size: 12pt; color: #3366ff;">You may be interested to read :&nbsp;<a style="color: #3366ff;" href="https://net2.com/how-to-keep-ubuntu-clean/">How to keep Ubuntu clean?</a></span></strong></p><h2><a id="post-145-_ust35e0634n"></a>Using Baobab (Disk Usage Analyzer)</h2><p>Formerly known as Baobab, Disk Usage Analyzer, is a GNOME graphical utility for analyzing disk usage. Like a file explorer, Baobab offers an easy to read menu-driven graphical interface representation of the content of the disk drive. The user can scan a selection of specific parts of filesystem be it a single folder, the filesystem in its entirety and even remote directories.</p><p>In order to install Baobab, issue the command below :</p><p><span style="font-family: 'courier new', courier, monospace;">sudo apt install baobab</span></p><p><noscript><img class="aligncenter wp-image-1018 size-full" src="https://net2.com/wp-content/uploads/2019/08/baobao-compressor.jpg" alt="sudo apt install baobab" width="1344" height="448" srcset="https://net2.com/wp-content/uploads/2019/08/baobao-compressor.jpg 1344w, https://net2.com/wp-content/uploads/2019/08/baobao-compressor-300x100.jpg 300w, https://net2.com/wp-content/uploads/2019/08/baobao-compressor-768x256.jpg 768w, https://net2.com/wp-content/uploads/2019/08/baobao-compressor-1024x341.jpg 1024w" sizes="(max-width: 1344px) 100vw, 1344px" /></noscript><img class="lazyload aligncenter wp-image-1018 size-full" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%201344%20448%22%3E%3C/svg%3E' data-src="https://net2.com/wp-content/uploads/2019/08/baobao-compressor.jpg" alt="sudo apt install baobab" width="1344" height="448" data-srcset="https://net2.com/wp-content/uploads/2019/08/baobao-compressor.jpg 1344w, https://net2.com/wp-content/uploads/2019/08/baobao-compressor-300x100.jpg 300w, https://net2.com/wp-content/uploads/2019/08/baobao-compressor-768x256.jpg 768w, https://net2.com/wp-content/uploads/2019/08/baobao-compressor-1024x341.jpg 1024w" data-sizes="(max-width: 1344px) 100vw, 1344px" /></p><p style="text-align: left;"><span style="font-size: 12pt;"><strong><span style="color: #3366ff;">You may be interested to read:&nbsp;<a style="color: #3366ff;" href="https://net2.com/how-to-install-and-uninstall-applications-in-ubuntu-a-beginners-guide/">How to install and uninstall applications in Ubuntu ? A Beginner’s guide</a><br /> </span></strong></span><br /> And then simply call baobab to launch it. You will see the window below :</p><p><noscript><img class="aligncenter wp-image-1019 size-full" src="https://net2.com/wp-content/uploads/2019/08/disk-usage-analyzer-compressor.jpg" alt="disk usage analyzer" width="1344" height="678" srcset="https://net2.com/wp-content/uploads/2019/08/disk-usage-analyzer-compressor.jpg 1344w, https://net2.com/wp-content/uploads/2019/08/disk-usage-analyzer-compressor-300x151.jpg 300w, https://net2.com/wp-content/uploads/2019/08/disk-usage-analyzer-compressor-768x387.jpg 768w, https://net2.com/wp-content/uploads/2019/08/disk-usage-analyzer-compressor-1024x517.jpg 1024w" sizes="(max-width: 1344px) 100vw, 1344px" /></noscript><img class="lazyload aligncenter wp-image-1019 size-full" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%201344%20678%22%3E%3C/svg%3E' data-src="https://net2.com/wp-content/uploads/2019/08/disk-usage-analyzer-compressor.jpg" alt="disk usage analyzer" width="1344" height="678" data-srcset="https://net2.com/wp-content/uploads/2019/08/disk-usage-analyzer-compressor.jpg 1344w, https://net2.com/wp-content/uploads/2019/08/disk-usage-analyzer-compressor-300x151.jpg 300w, https://net2.com/wp-content/uploads/2019/08/disk-usage-analyzer-compressor-768x387.jpg 768w, https://net2.com/wp-content/uploads/2019/08/disk-usage-analyzer-compressor-1024x517.jpg 1024w" data-sizes="(max-width: 1344px) 100vw, 1344px" /></p><p>Now you can choose the filesystem to analyze. Below you can see the folder hierarchy along with information about the size, modification date…</p><p>On the right part of the snapshot, you will see a kind of chart map which reflects the tree information. You can use this to look at the sizes of the folders and their content as well.</p><p><noscript><img class="aligncenter wp-image-1020 size-full" src="https://net2.com/wp-content/uploads/2019/08/disk-usage-analyzer-2-compressor.jpg" alt="disk usage analyzer 2" width="1344" height="886" srcset="https://net2.com/wp-content/uploads/2019/08/disk-usage-analyzer-2-compressor.jpg 1344w, https://net2.com/wp-content/uploads/2019/08/disk-usage-analyzer-2-compressor-300x198.jpg 300w, https://net2.com/wp-content/uploads/2019/08/disk-usage-analyzer-2-compressor-768x506.jpg 768w, https://net2.com/wp-content/uploads/2019/08/disk-usage-analyzer-2-compressor-1024x675.jpg 1024w" sizes="(max-width: 1344px) 100vw, 1344px" /></noscript><img class="lazyload aligncenter wp-image-1020 size-full" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%201344%20886%22%3E%3C/svg%3E' data-src="https://net2.com/wp-content/uploads/2019/08/disk-usage-analyzer-2-compressor.jpg" alt="disk usage analyzer 2" width="1344" height="886" data-srcset="https://net2.com/wp-content/uploads/2019/08/disk-usage-analyzer-2-compressor.jpg 1344w, https://net2.com/wp-content/uploads/2019/08/disk-usage-analyzer-2-compressor-300x198.jpg 300w, https://net2.com/wp-content/uploads/2019/08/disk-usage-analyzer-2-compressor-768x506.jpg 768w, https://net2.com/wp-content/uploads/2019/08/disk-usage-analyzer-2-compressor-1024x675.jpg 1024w" data-sizes="(max-width: 1344px) 100vw, 1344px" /></p><div class='code-block code-block-3' style='margin: 8px 0; clear: both;'> <script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle"
style="display:block; text-align:center;"
data-ad-layout="in-article"
data-ad-format="fluid"
data-ad-client="ca-pub-4222719099368092"
data-ad-slot="7786447957"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div></div><div class="post-tags clr"> <span class="owp-tag-text">Tags: </span><a href="https://net2.com/tag/baobab/" rel="tag">baobab</a><span class="owp-sep">,</span> <a href="https://net2.com/tag/command-du/" rel="tag">command du</a><span class="owp-sep">,</span> <a href="https://net2.com/tag/command-find/" rel="tag">command find</a><span class="owp-sep">,</span> <a href="https://net2.com/tag/command-ls/" rel="tag">command ls</a><span class="owp-sep">,</span> <a href="https://net2.com/tag/ubuntu-largest-files/" rel="tag">ubuntu largest files</a></div><nav class="navigation post-navigation" role="navigation"><h2 class="screen-reader-text">Continue Reading</h2><div class="nav-links"><div class="nav-next"><a href="https://net2.com/how-to-set-up-a-firewall-on-ubuntu-18-04/" rel="next"><span class="title"><i class="fa fa-long-arrow-right"></i>Next Post</span><span class="post-title">How to set up a firewall on Ubuntu 18.04 ?</span></a></div></div></nav><div class="wpdiscuz_top_clearing"></div><div id="comments" class="comments-area"><div id="respond" style="width: 0;height: 0;clear: both;margin: 0;padding: 0;"></div><h3 id="wc-comment-header"> Leave a Reply</h3><div id="wpcomm" class="wpdiscuz_unauth wpd-default"><div class="wpdiscuz-form-top-bar"><div class="wpdiscuz-ftb-left"><div id="wc_show_hide_loggedin_username"></div></div><div class="wpd-clear"></div></div><div class="wc_social_plugin_wrapper"></div><div class="wc-form-wrapper wc-main-form-wrapper"  id='wc-main-form-wrapper-0_0' ><div class="wpdiscuz-comment-message" style="display: block;"></div><form class="wc_comm_form wc_main_comm_form" method="post"  enctype="multipart/form-data"><div class="wc-field-comment"><div class="wpdiscuz-item wc-field-textarea" ><div class="wpdiscuz-textarea-wrap "><div class="wc-field-avatararea"> <noscript><img alt='avatar' src='https://secure.gravatar.com/avatar/?s=40&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=80&#038;d=mm&#038;r=g 2x' class='avatar avatar-40 photo avatar-default' height='40' width='40' /></noscript><img alt='avatar' src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2040%2040%22%3E%3C/svg%3E' data-src='https://secure.gravatar.com/avatar/?s=40&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/?s=80&#038;d=mm&#038;r=g 2x' class='lazyload avatar avatar-40 photo avatar-default' height='40' width='40' /></div><textarea id="wc-textarea-0_0"   placeholder="Start the discussion..." required name="wc_comment" class="wc_comment wpd-field"></textarea></div></div><div class="clearfix"></div></div><div class="wc-form-footer"  style="display: none;"><div class="wpd-form-row"><div class="wpd-form-col-left"><div class="wpdiscuz-item wc_name-wrapper wpd-has-icon"><div class="wpd-field-icon"><i class="fas fa-user"></i></div> <input value="" required="required" class="wc_name wpd-field" type="text" name="wc_name" placeholder="Name*" maxlength="50" pattern=".{3,50}" title=""></div><div class="wpdiscuz-item wc_email-wrapper wpd-has-icon"><div class="wpd-field-icon"><i class="fas fa-at"></i></div> <input value="" required="required" class="wc_email wpd-field" type="email" name="wc_email" placeholder="Email*"></div><div class="wpdiscuz-item wc_website-wrapper wpd-has-icon"><div class="wpd-field-icon"><i class="fas fa-link"></i></div> <input value="" class="wc_website wpd-field" type="text" name="wc_website" placeholder="Website"></div></div><div class="wpd-form-col-right"><div class="wc-field-captcha wpdiscuz-item wc_captcha-wrapper"><div class="wc-bin-captcha"> <i class="fas fa-shield-alt"></i>This comment form is under antispam protection</div></div><div class="wc-field-submit"> <label class="wpd_label" title="Notify of new replies to this comment"> <input id="wc_notification_new_comment-0_0" class="wc_notification_new_comment-0_0 wpd_label__checkbox" value="comment" type="checkbox" name="wpdiscuz_notification_type" /> <span class="wpd_label__text"> <span class="wpd_label__check"> <i class="fas fa-bell wpdicon wpdicon-on"></i> <i class="fas fa-bell-slash wpdicon wpdicon-off"></i> </span> </span> </label> <input class="wc_comm_submit wc_not_clicked button alt" type="submit" name="submit" value="Post Comment"></div></div><div class="clearfix"></div></div></div><div class="clearfix"></div> <input type="hidden" class="wpdiscuz_unique_id" value="0_0" name="wpdiscuz_unique_id"></form></div><div id = "wpdiscuz_hidden_secondary_form" style = "display: none;"><div class="wc-form-wrapper wc-secondary-form-wrapper"  id='wc-secondary-form-wrapper-wpdiscuzuniqueid'  style='display: none;' ><div class="wpdiscuz-comment-message" style="display: block;"></div><div class="wc-secondary-forms-social-content"></div><div class="clearfix"></div><form class="wc_comm_form wc-secondary-form-wrapper" method="post"  enctype="multipart/form-data"><div class="wc-field-comment"><div class="wpdiscuz-item wc-field-textarea" ><div class="wpdiscuz-textarea-wrap "><div class="wc-field-avatararea"> <noscript><img alt='avatar' src='https://secure.gravatar.com/avatar/?s=48&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=96&#038;d=mm&#038;r=g 2x' class='avatar avatar-48 photo avatar-default' height='48' width='48' /></noscript><img alt='avatar' src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2048%2048%22%3E%3C/svg%3E' data-src='https://secure.gravatar.com/avatar/?s=48&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/?s=96&#038;d=mm&#038;r=g 2x' class='lazyload avatar avatar-48 photo avatar-default' height='48' width='48' /></div><textarea id="wc-textarea-wpdiscuzuniqueid"   placeholder="Join the discussion..." required name="wc_comment" class="wc_comment wpd-field"></textarea></div></div><div class="clearfix"></div></div><div class="wc-form-footer"  style="display: none;"><div class="wpd-form-row"><div class="wpd-form-col-left"><div class="wpdiscuz-item wc_name-wrapper wpd-has-icon"><div class="wpd-field-icon"><i class="fas fa-user"></i></div> <input value="" required="required" class="wc_name wpd-field" type="text" name="wc_name" placeholder="Name*" maxlength="50" pattern=".{3,50}" title=""></div><div class="wpdiscuz-item wc_email-wrapper wpd-has-icon"><div class="wpd-field-icon"><i class="fas fa-at"></i></div> <input value="" required="required" class="wc_email wpd-field" type="email" name="wc_email" placeholder="Email*"></div><div class="wpdiscuz-item wc_website-wrapper wpd-has-icon"><div class="wpd-field-icon"><i class="fas fa-link"></i></div> <input value="" class="wc_website wpd-field" type="text" name="wc_website" placeholder="Website"></div></div><div class="wpd-form-col-right"><div class="wc-field-captcha wpdiscuz-item wc_captcha-wrapper"><div class="wc-bin-captcha"> <i class="fas fa-shield-alt"></i>This comment form is under antispam protection</div></div><div class="wc-field-submit"> <label class="wpd_label" title="Notify of new replies to this comment"> <input id="wc_notification_new_comment-wpdiscuzuniqueid" class="wc_notification_new_comment-wpdiscuzuniqueid wpd_label__checkbox" value="comment" type="checkbox" name="wpdiscuz_notification_type" /> <span class="wpd_label__text"> <span class="wpd_label__check"> <i class="fas fa-bell wpdicon wpdicon-on"></i> <i class="fas fa-bell-slash wpdicon wpdicon-off"></i> </span> </span> </label> <input class="wc_comm_submit wc_not_clicked button alt" type="submit" name="submit" value="Post Comment"></div></div><div class="clearfix"></div></div></div><div class="clearfix"></div> <input type="hidden" class="wpdiscuz_unique_id" value="wpdiscuzuniqueid" name="wpdiscuz_unique_id"></form></div></div><div class="wpdiscuz-front-actions"><div class="wpdiscuz-sbs-wrap"> <span><i class="far fa-envelope" aria-hidden="true"></i>&nbsp; Subscribe &nbsp;<i class="fas fa-caret-down" aria-hidden="true"></i></span></div><div class="clearfix"></div></div><div class="wpdiscuz-subscribe-bar wpdiscuz-hidden"><form action="https://net2.com/wp-admin/admin-ajax.php?action=addSubscription" method="post" id="wpdiscuz-subscribe-form"><div class="wpdiscuz-subscribe-form-intro">Notify of</div><div class="wpdiscuz-subscribe-form-option" style="width:40%;"> <select class="wpdiscuz_select" name="wpdiscuzSubscriptionType" ><option value="post">new follow-up comments</option><option value="all_comment" >new replies to my comments</option> </select></div><div class="wpdiscuz-item wpdiscuz-subscribe-form-email"> <input  class="email" type="email" name="wpdiscuzSubscriptionEmail" required="required" value="" placeholder="Email"/></div><div class="wpdiscuz-subscribe-form-button"> <input id="wpdiscuz_subscription_button" type="submit" value="&rsaquo;" name="wpdiscuz_subscription_button" /></div> <input type="hidden" id="wpdiscuz_subscribe_form_nonce" name="wpdiscuz_subscribe_form_nonce" value="6aed662b90" /><input type="hidden" name="_wp_http_referer" value="/how-to-find-the-largest-files-on-linux/" /> <input type="hidden" value="145" name="wpdiscuzSubscriptionPostId" /></form><div class="wpdiscuz_clear"></div></div><div id="wcThreadWrapper" class="wc-thread-wrapper"><div class="wpdiscuz-comment-pagination"></div></div><div class="wpdiscuz_clear"></div></div></div><div id="wpdiscuz-loading-bar" class="wpdiscuz-loading-bar wpdiscuz-loading-bar-unauth"></div></article></div></div><aside id="right-sidebar" class="sidebar-container widget-area sidebar-primary" itemscope="itemscope" itemtype="http://schema.org/WPSideBar"><div id="right-sidebar-inner" class="clr"><div id="search-2" class="sidebar-box widget_search clr"><h4 class="widget-title">Search</h4><form method="get" class="searchform" id="searchform" action="https://net2.com/"> <input type="text" class="field" name="s" id="s" placeholder="Search"> <input type="hidden" name="post_type" value="post"></form></div><div id="wpp-3" class="sidebar-box popular-posts clr"><h4 class="widget-title">Most popular posts</h4><ul class="wpp-list"><li> <a href="https://net2.com/how-to-fix-wifi-not-working-on-ubuntu/" title="How to fix WiFi not working on Ubuntu?" class="wpp-post-title" target="_self">How to fix WiFi not working on Ubuntu?</a></li><li> <a href="https://net2.com/how-to-install-java-on-ubuntu/" title="How to Install Java on Ubuntu ?" class="wpp-post-title" target="_self">How to Install Java on Ubuntu ?</a></li><li> <a href="https://net2.com/how-to-fix-ubuntu-update-errors/" title="How to fix Ubuntu update errors ?" class="wpp-post-title" target="_self">How to fix Ubuntu update errors ?</a></li><li> <a href="https://net2.com/how-to-solve-ubi-partman-failed-with-exit-code-10-in-ubuntu-18-04/" title="How to solve &#8220;ubi-partman failed with exit code 10&#8221; on ubuntu 18.04 ?" class="wpp-post-title" target="_self">How to solve &#8220;ubi-partman failed with exit code 10&#8221; on ubuntu 18.04 ?</a></li><li> <a href="https://net2.com/how-to-fix-system-program-problem-detected-error-in-ubuntu/" title="How to fix “system program problem detected” error on Ubuntu ?" class="wpp-post-title" target="_self">How to fix “system program problem detected” error on Ubuntu ?</a></li><li> <a href="https://net2.com/how-to-fix-unmet-dependencies-error-in-ubuntu/" title="How to Fix Unmet Dependencies Error on Ubuntu?" class="wpp-post-title" target="_self">How to Fix Unmet Dependencies Error on Ubuntu?</a></li><li> <a href="https://net2.com/how-to-set-up-a-firewall-on-ubuntu-18-04/" title="How to set up a firewall on Ubuntu 18.04 ?" class="wpp-post-title" target="_self">How to set up a firewall on Ubuntu 18.04 ?</a></li><li> <a href="https://net2.com/how-to-install-samba-on-ubuntu/" title="How to install Samba on Ubuntu ?" class="wpp-post-title" target="_self">How to install Samba on Ubuntu ?</a></li><li class="current"> <a  title="How to find the largest files on Linux ?" class="wpp-post-title" target="_self">How to find the largest files on Linux ?</a></li><li> <a href="https://net2.com/how-to-install-ubuntu-in-windows-subsystem-for-linux/" title="How to install Ubuntu on Windows Subsystem for Linux ?" class="wpp-post-title" target="_self">How to install Ubuntu on Windows Subsystem for Linux ?</a></li></ul></div><div id="recent-posts-2" class="sidebar-box widget_recent_entries clr"><h4 class="widget-title">Recent Posts</h4><ul><li> <a href="https://net2.com/fedora-29-release-features/">Fedora 29 release features</a> <span class="post-date">October 5, 2019</span></li><li> <a href="https://net2.com/how-to-fix-ubuntu-boot-issues/">How to fix Ubuntu boot issues ?</a> <span class="post-date">October 3, 2019</span></li><li> <a href="https://net2.com/how-to-install-teamviewer-in-linux/">How to install TeamViewer in Linux ?</a> <span class="post-date">October 1, 2019</span></li><li> <a href="https://net2.com/switching-between-different-linux-distributions-without-losing-data/">Switching between different Linux distributions without losing data</a> <span class="post-date">September 29, 2019</span></li><li> <a href="https://net2.com/how-to-install-arch-linux/">How to Install Arch Linux?</a> <span class="post-date">September 27, 2019</span></li></ul></div><div id="newsletterwidgetminimal-2" class="sidebar-box widget_newsletterwidgetminimal clr"><h4 class="widget-title">Stay informed by joining our newsletter!</h4><div class="tnp tnp-widget-minimal"><form class="tnp-form" action="https://net2.com/?na=s" method="post" onsubmit="return newsletter_check(this)"><input type="hidden" name="nr" value="widget-minimal"/><input class="tnp-email" type="email" required name="ne" value="" placeholder="Email"><input class="tnp-submit" type="submit" value="Subscribe"></form></div></div></div></aside></div></main><footer id="footer" class="site-footer" itemscope="itemscope" itemtype="http://schema.org/WPFooter"><div id="footer-inner" class="clr"><div id="footer-widgets" class="oceanwp-row clr"><div class="footer-widgets-inner container"><div class="footer-box span_1_of_4 col col-1"><div id="ocean_social-4" class="footer-widget widget-oceanwp-social social-widget clr"><ul class="oceanwp-social-icons no-transition style-dark"><li class="oceanwp-twitter"><a href="https://twitter.com/Amin_net2" title="Twitter"  target="_blank"><i class="fa fa-twitter"></i></a></li><li class="oceanwp-facebook"><a href="https://www.facebook.com/aminnahdy.net2/" title="Facebook"  target="_blank"><i class="fa fa-facebook"></i></a></li><li class="oceanwp-pinterest"><a href="https://www.pinterest.com/Amin_net2/" title="Pinterest"  target="_blank"><i class="fa fa-pinterest-p"></i></a></li></ul></div></div><div class="footer-box span_1_of_4 col col-2"></div><div class="footer-box span_1_of_4 col col-3 "></div><div class="footer-box span_1_of_4 col col-4"></div></div></div><div id="footer-bottom" class="clr"><div id="footer-bottom-inner" class="container clr"><div id="footer-bottom-menu" class="navigation clr"><div class="menu-footer-container"><ul id="menu-footer" class="menu"><li id="menu-item-28" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28"><a href="https://net2.com/contact-us/">Contact us</a></li><li id="menu-item-29" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29"><a href="https://net2.com/about/">About</a></li><li id="menu-item-30" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-30"><a href="https://net2.com/privacy-policy/">Privacy Policy</a></li></ul></div></div><div id="copyright" class="clr" role="contentinfo"> Copyright net2.com all rights reserved 2019</div></div></div></div></footer></div></div> <a id="scroll-top" class="scroll-top-right" href="#"><span class="fa fa-angle-up"></span></a><div id="sidr-close"> <a href="#" class="toggle-sidr-close"> <i class="icon icon-close"></i><span class="close-text">Close Menu</span> </a></div><div id="mobile-nav" class="navigation clr"><ul id="menu-main_menu-1" class="mobile-menu dropdown-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-23"><a href="https://net2.com/">Home</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-805"><a href="https://net2.com/category/linux/ubuntu/">Ubuntu</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1236"><a href="https://net2.com/category/linux/ubuntu_tips_and_tricks/">Ubuntu Tips &#038; Tricks</a></li></ul></div><div id="mobile-menu-search" class="clr"><form method="get" action="https://net2.com/" class="mobile-searchform"> <input type="search" name="s" autocomplete="off" placeholder="Search" /> <button type="submit" class="searchform-submit"> <i class="icon icon-magnifier"></i> </button> <input type="hidden" name="post_type" value="post"></form></div><div id="csbwfs-delaydiv"><div class="csbwfs-social-widget"  id="csbwfs-left" title="Share This With Your Friends"  style="top:25%;left:0;"><div class="csbwfs-show"><a href="javascript:" title="Show Buttons" id="csbwfs-show"><noscript><img src="https://net2.com/wp-content/plugins/custom-share-buttons-with-floating-sidebar/images/hide-l.png" alt="Show Buttons"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20%20%22%3E%3C/svg%3E' data-src="https://net2.com/wp-content/plugins/custom-share-buttons-with-floating-sidebar/images/hide-l.png" alt="Show Buttons"></a></div><div id="csbwfs-social-inner"><div class="csbwfs-sbutton csbwfsbtns"><div id="csbwfs-fb" class="csbwfs-fb"><a href="javascript:" onclick="javascript:window.open('//www.facebook.com/sharer/sharer.php?u=https://net2.com/how-to-find-the-largest-files-on-linux/', '', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=300,width=600');return false;" target="_blank" title="Share On Facebook" ><i class="csbwfs_facebook"></i></a></div></div><div class="csbwfs-sbutton csbwfsbtns"><div id="csbwfs-tw" class="csbwfs-tw"><a href="javascript:" onclick="window.open('//twitter.com/share?url=https://net2.com/how-to-find-the-largest-files-on-linux/&text=How%20to%20find%20the%20largest%20files%20on%20Linux%20%3F','_blank','width=800,height=300')" title="Share On Twitter" ><i class="csbwfs_twitter"></i></a></div></div><div class="csbwfs-sbutton csbwfsbtns"><div id="csbwfs-li" class="csbwfs-li"><a href="javascript:" onclick="javascript:window.open('//www.linkedin.com/cws/share?mini=true&url=https://net2.com/how-to-find-the-largest-files-on-linux/','','menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=800');return false;" title="Share On Linkedin" ><i class="csbwfs_linkedin"></i></a></div></div><div class="csbwfs-sbutton csbwfsbtns"><div id="csbwfs-pin" class="csbwfs-pin"><a onclick="javascript:void((function(){var e=document.createElement('script');e.setAttribute('type','text/javascript');e.setAttribute('charset','UTF-8');e.setAttribute('src','//assets.pinterest.com/js/pinmarklet.js?r='+Math.random()*99999999);document.body.appendChild(e)})());" href="javascript:void(0);"  title="Share On Pinterest"><i class="csbwfs_pinterest"></i></a></div></div><div class="csbwfs-sbutton csbwfsbtns"><div id="csbwfs-re" class="csbwfs-re"><a onclick="window.open('//reddit.com/submit?url=https://net2.com/how-to-find-the-largest-files-on-linux/&amp;title=How%20to%20find%20the%20largest%20files%20on%20Linux%20%3F','Reddit','toolbar=0,status=0,width=1000,height=800');" href="javascript:void(0);"  title="Share On Reddit"><i class="csbwfs_reddit"></i></a></div></div></div><div class="csbwfs-hide"><a href="javascript:" title="Hide Buttons" id="csbwfs-hide"><noscript><img src="https://net2.com/wp-content/plugins/custom-share-buttons-with-floating-sidebar/images/hide.png" alt="Hide Buttons"></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20%20%22%3E%3C/svg%3E' data-src="https://net2.com/wp-content/plugins/custom-share-buttons-with-floating-sidebar/images/hide.png" alt="Hide Buttons"></a></div></div></div><script>var windWidth=jQuery( window ).width();
//alert(windWidth);
var animateWidth;
var defaultAnimateWidth;
jQuery(document).ready(function()
{ 
animateWidth="55";
defaultAnimateWidth= animateWidth-10;
animateHeight="49";
defaultAnimateHeight= animateHeight-2;jQuery("div.csbwfsbtns a").hover(function(){
jQuery(this).animate({width:animateWidth});
},function(){
jQuery(this).stop( true, true ).animate({width:defaultAnimateWidth});
});jQuery("div.csbwfs-show").hide();
jQuery("div.csbwfs-show a").click(function(){
jQuery("div#csbwfs-social-inner").show(500);
jQuery("div.csbwfs-show").hide(500);
jQuery("div.csbwfs-hide").show(500);
csbwfsSetCookie("csbwfs_show_hide_status","active","1");
});
jQuery("div.csbwfs-hide a").click(function(){
jQuery("div.csbwfs-show").show(500);
jQuery("div.csbwfs-hide").hide(500);
jQuery("div#csbwfs-social-inner").hide(500);
csbwfsSetCookie("csbwfs_show_hide_status","in_active","1");
});var button_status=csbwfsGetCookie("csbwfs_show_hide_status");
if (button_status =="in_active") {
jQuery("div.csbwfs-show").show();
jQuery("div.csbwfs-hide").hide();
jQuery("div#csbwfs-social-inner").hide();
} else {
jQuery("div#csbwfs-social-inner").show();
jQuery("div.csbwfs-show").hide();
jQuery("div.csbwfs-hide").show();
}});</script><script>csbwfsCheckCookie();function csbwfsSetCookie(cname,cvalue,exdays) {
var d = new Date();
d.setTime(d.getTime() + (exdays*24*60*60*1000));
var expires = "expires=" + d.toGMTString();
document.cookie = cname+"="+cvalue+"; "+expires;
}
function csbwfsGetCookie(cname) {
var name = cname + "=";
var ca = document.cookie.split(';');
for(var i=0; i<ca.length; i++) {
var c = ca[i];
while (c.charAt(0)==' ') c = c.substring(1);
if (c.indexOf(name) != -1) {
return c.substring(name.length, c.length);
}
}
return "";
}
function csbwfsCheckCookie() {
var hideshowhide = ""
var button_status=csbwfsGetCookie("csbwfs_show_hide_status");
if (button_status != "") {
} else {
csbwfsSetCookie("csbwfs_show_hide_status", "active",1);
}
if(hideshowhide=="yes")
{
csbwfsSetCookie("csbwfs_show_hide_status", "active",0);
}
}</script><a id='wpdUserContentInfoAnchor' style='display:none;' rel='#wpdUserContentInfo' data-wpd-lity>wpDiscuz</a><div id='wpdUserContentInfo' style='overflow:auto;background:#FDFDF6;padding:20px;width:600px;max-width:100%;border-radius:6px;' class='lity-hide'></div><noscript><style>.lazyload{display:none;}</style></noscript><script data-noptimize="1">window.lazySizesConfig=window.lazySizesConfig||{};window.lazySizesConfig.loadMode=1;</script><script async data-noptimize="1" src='https://net2.com/wp-content/plugins/autoptimize/classes/external/js/lazysizes.min.js'></script><script type='text/javascript'>var wpcf7 = {"apiSettings":{"root":"https:\/\/net2.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};</script> <script type='text/javascript' src='https://net2.com/wp-content/cache/autoptimize/autoptimize_single_1534f06aa2b1b721a45372f8238e2461.php?ver=5.1.4'></script> <script type='text/javascript' src='https://net2.com/wp-content/cache/autoptimize/autoptimize_single_a48d588330452419959e91cf40f2cd23.php?ver=5.3.2'></script> <script type='text/javascript' src='https://net2.com/wp-content/plugins/wpdiscuz/assets/third-party/autogrow/jquery.autogrowtextarea.min.js?ver=5.3.2'></script> <script type='text/javascript' src='https://net2.com/wp-includes/js/jquery/jquery.form.min.js?ver=4.2.1'></script> <script type='text/javascript'>var wpdiscuzAjaxObj = {"url":"https:\/\/net2.com\/wp-admin\/admin-ajax.php","customAjaxUrl":"https:\/\/net2.com\/wp-content\/plugins\/wpdiscuz\/utils\/ajax\/wpdiscuz-ajax.php","wpdiscuz_options":{"wc_hide_replies_text":"Hide Replies","wc_show_replies_text":"View Replies","wc_msg_required_fields":"Please fill out required fields","wc_invalid_field":"Some of field value is invalid","wc_error_empty_text":"please fill out this field to comment","wc_error_url_text":"url is invalid","wc_error_email_text":"email address is invalid","wc_invalid_captcha":"Invalid Captcha Code","wc_login_to_vote":"You Must Be Logged In To Vote","wc_deny_voting_from_same_ip":"You are not allowed to vote for this comment","wc_self_vote":"You cannot vote for your comment","wc_vote_only_one_time":"You've already voted for this comment","wc_voting_error":"Voting Error","wc_held_for_moderate":"Comment awaiting moderation","wc_comment_edit_not_possible":"Sorry, this comment no longer possible to edit","wc_comment_not_updated":"Sorry, the comment was not updated","wc_comment_not_edited":"You've not made any changes","wc_new_comment_button_text":"new comment","wc_new_comments_button_text":"new comments","wc_new_reply_button_text":"new reply on your comment","wc_new_replies_button_text":"new replies on your comments","wc_msg_input_min_length":"Input is too short","wc_msg_input_max_length":"Input is too long","wc_follow_user":"Follow this user","wc_unfollow_user":"Unfollow this user","wc_follow_success":"You started following this comment author","wc_follow_canceled":"You stopped following this comment author.","wc_follow_email_confirm":"Please check your email and confirm the user following request.","wc_follow_email_confirm_fail":"Sorry, we couldn't send confirmation email.","wc_follow_login_to_follow":"Please login to follow users.","wc_follow_impossible":"We are sorry, but you can't follow this user.","wc_follow_not_added":"Following failed. Please try again later.","is_user_logged_in":false,"commentListLoadType":"2","commentListUpdateType":"0","commentListUpdateTimer":"30","liveUpdateGuests":"1","wc_comment_bg_color":"#FEFEFE","wc_reply_bg_color":"#F8F8F8","wpdiscuzCommentsOrder":"asc","wpdiscuzCommentOrderBy":"comment_date_gmt","commentsVoteOrder":false,"wordpressThreadCommentsDepth":"5","wordpressIsPaginate":"0","commentTextMaxLength":null,"storeCommenterData":100000,"isCaptchaInSession":true,"isGoodbyeCaptchaActive":false,"socialLoginAgreementCheckbox":0,"enableFbLogin":0,"enableFbShare":0,"facebookAppID":"","facebookUseOAuth2":0,"enableGoogleLogin":0,"googleAppID":"","cookiehash":"176c141086e36b5e193c0ea47b760a71","isLoadOnlyParentComments":"1","ahk":"v9^919v409xi10ad(qjcat##ss98zl)s","enableDropAnimation":1,"isNativeAjaxEnabled":1,"cookieCommentsSorting":"wpdiscuz_comments_sorting","enableLastVisitCookie":0,"version":"5.3.2","wc_post_id":145,"loadLastCommentId":0,"lastVisitKey":"wpdiscuz_last_visit","isCookiesEnabled":true,"wc_captcha_show_for_guest":"0","wc_captcha_show_for_members":"0","is_email_field_required":"1"}};</script> <script type='text/javascript' src='https://net2.com/wp-content/cache/autoptimize/autoptimize_single_e036b0d5c685fca41431fc4a78250e5f.php?ver=5.3.2'></script> <script type='text/javascript'>var wpdiscuzUCObj = {"msgConfirmDeleteComment":"Are you sure you want to delete this comment?","msgConfirmCancelSubscription":"Are you sure you want to cancel this subscription?","msgConfirmCancelFollow":"Are you sure you want to cancel this follow?"};</script> <script type='text/javascript' src='https://net2.com/wp-content/cache/autoptimize/autoptimize_single_211059733a7ef81bfb103b7537206d65.php?ver=5.3.2'></script> <script type='text/javascript' src='https://net2.com/wp-content/cache/autoptimize/autoptimize_single_307fd38c30146c2bf8a4dfd7ae33db88.php?ver=5.3.2'></script> <script type='text/javascript' src='https://www.google.com/recaptcha/api.js?render=6LfC3LIUAAAAAPuQlovhyPa52-7pFt0hAH8Z760b&#038;ver=3.0'></script> <script type='text/javascript' src='https://net2.com/wp-includes/js/comment-reply.min.js?ver=5.2.3'></script> <script type='text/javascript' src='https://net2.com/wp-includes/js/imagesloaded.min.js?ver=3.2.0'></script> <script type='text/javascript' src='https://net2.com/wp-content/cache/autoptimize/autoptimize_single_092e0f4c6cf9e1699af003bcedb06089.php?ver=1.6.7'></script> <script type='text/javascript' src='https://net2.com/wp-content/themes/oceanwp/assets/js/third/lightbox.min.js?ver=1.6.10'></script> <script type='text/javascript'>var oceanwpLocalize = {"isRTL":"","menuSearchStyle":"drop_down","sidrSource":"#sidr-close, #mobile-nav, #mobile-menu-search","sidrDisplace":"1","sidrSide":"left","sidrDropdownTarget":"icon","verticalHeaderTarget":"icon","customSelects":".woocommerce-ordering .orderby, #dropdown_product_cat, .widget_categories select, .widget_archive select, .single-product .variations_form .variations select","ajax_url":"https:\/\/net2.com\/wp-admin\/admin-ajax.php"};</script> <script type='text/javascript' src='https://net2.com/wp-content/themes/oceanwp/assets/js/main.min.js?ver=1.6.10'></script> <script type='text/javascript'>var newsletter = {"messages":{"email_error":"Email address is not correct","name_error":"Name is required","surname_error":"Last name is required","privacy_error":"You must accept the privacy policy"},"profile_max":"20"};</script> <script type='text/javascript' src='https://net2.com/wp-content/cache/autoptimize/autoptimize_single_b562667fe2faa8b03924bed00a98d7ec.php?ver=6.1.6'></script> <script type='text/javascript' src='https://net2.com/wp-includes/js/wp-embed.min.js?ver=5.2.3'></script> <!--[if lt IE 9]> <script type='text/javascript' src='https://net2.com/wp-content/themes/oceanwp/assets/js//third/html5.min.js?ver=1.6.10'></script> <![endif]--> <script type="text/javascript">( function( grecaptcha, sitekey, actions ) {
var wpcf7recaptcha = {
execute: function( action ) {
grecaptcha.execute(
sitekey,
{ action: action }
).then( function( token ) {
var forms = document.getElementsByTagName( 'form' );
for ( var i = 0; i < forms.length; i++ ) {
var fields = forms[ i ].getElementsByTagName( 'input' );
for ( var j = 0; j < fields.length; j++ ) {
var field = fields[ j ];
if ( 'g-recaptcha-response' === field.getAttribute( 'name' ) ) {
field.setAttribute( 'value', token );
break;
}
}
}
} );
},
executeOnHomepage: function() {
wpcf7recaptcha.execute( actions[ 'homepage' ] );
},
executeOnContactform: function() {
wpcf7recaptcha.execute( actions[ 'contactform' ] );
},
};
grecaptcha.ready(
wpcf7recaptcha.executeOnHomepage
);
document.addEventListener( 'change',
wpcf7recaptcha.executeOnContactform, false
);
document.addEventListener( 'wpcf7submit',
wpcf7recaptcha.executeOnHomepage, false
);
} )(
grecaptcha,
'6LfC3LIUAAAAAPuQlovhyPa52-7pFt0hAH8Z760b',
{"homepage":"homepage","contactform":"contactform"}
);</script> </body></html><!-- WP Fastest Cache file was created in 1.0339510440826 seconds, on 05-10-19 23:02:57 -->