<!DOCTYPE html><html class="html" lang="en-US" prefix="og: http://ogp.me/ns#" itemscope itemtype="http://schema.org/WebPage"><head><meta charset="UTF-8"><link rel="profile" href="https://gmpg.org/xfn/11"><!-- <link type="text/css" media="all" href="https://net2.com/wp-content/cache/autoptimize/css/autoptimize_1286e9e028cd78d1578d462c365b5b7b.css" rel="stylesheet" /> --><title>How to fix ‘E: Could not get lock /var/lib/dpkg/lock’ Error in Ubuntu</title><meta name="viewport" content="width=device-width, initial-scale=1"><meta name="description" content="Sometimes when users try to install an application by executing the usual apt command on Ubuntu, they get the following error: Other users might encounter"/><link rel="canonical" href="https://net2.com/how-to-fix-e-could-not-get-lock-var-lib-dpkg-lock-error-in-ubuntu/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="How to fix ‘E: Could not get lock /var/lib/dpkg/lock’ Error in Ubuntu" /><meta property="og:description" content="Sometimes when users try to install an application by executing the usual apt command on Ubuntu, they get the following error: Other users might encounter" /><meta property="og:url" content="https://net2.com/how-to-fix-e-could-not-get-lock-var-lib-dpkg-lock-error-in-ubuntu/" /><meta property="og:site_name" content="net2" /><meta property="article:tag" content="apt lock issue" /><meta property="article:tag" content="kill process" /><meta property="article:tag" content="lsof command" /><meta property="article:section" content="Linux" /><meta property="article:published_time" content="2020-01-28T18:58:17+01:00" /><meta property="article:modified_time" content="2020-01-25T10:38:39+01:00" /><meta property="og:updated_time" content="2020-01-25T10:38:39+01:00" /><meta property="og:image" content="https://net2.com/wp-content/uploads/2019/12/lock-error-ubuntu.jpg" /><meta property="og:image:secure_url" content="https://net2.com/wp-content/uploads/2019/12/lock-error-ubuntu.jpg" /><meta property="og:image:width" content="958" /><meta property="og:image:height" content="536" /><meta property="og:image:alt" content="How to fix ‘E: Could not get lock /var/lib/dpkg/lock’ Error in Ubuntu" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:description" content="Sometimes when users try to install an application by executing the usual apt command on Ubuntu, they get the following error: Other users might encounter" /><meta name="twitter:title" content="How to fix ‘E: Could not get lock /var/lib/dpkg/lock’ Error in Ubuntu" /><meta name="twitter:image" content="https://net2.com/wp-content/uploads/2019/12/lock-error-ubuntu.jpg" /> <script type='application/ld+json'>{"@context":"https:\/\/schema.org","@type":"Organization","url":"https:\/\/net2.com\/","sameAs":[],"@id":"https:\/\/net2.com\/#organization","name":"net2","logo":"https:\/\/net2.com\/wp-content\/uploads\/2019\/08\/LOGO-net2.png"}</script> <link rel='dns-prefetch' href='//www.google.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="net2 &raquo; Feed" href="https://net2.com/feed/" /><link rel="alternate" type="application/rss+xml" title="net2 &raquo; Comments Feed" href="https://net2.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="net2 &raquo; How to fix ‘E: Could not get lock /var/lib/dpkg/lock’ Error in Ubuntu Comments Feed" href="https://net2.com/how-to-fix-e-could-not-get-lock-var-lib-dpkg-lock-error-in-ubuntu/feed/" />  <script type="text/javascript" data-cfasync="false">var mi_version         = '7.10.3';
var mi_track_user      = true;
var mi_no_track_reason = '';
var disableStr = 'ga-disable-UA-146071783-1';
/* Function to detect opted out users */
function __gaTrackerIsOptedOut() {
return document.cookie.indexOf(disableStr + '=true') > -1;
}
/* Disable tracking if the opt-out cookie exists. */
if ( __gaTrackerIsOptedOut() ) {
window[disableStr] = true;
}
/* Opt-out function */
function __gaTrackerOptout() {
document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
window[disableStr] = true;
}
if ( mi_track_user ) {
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');
__gaTracker('create', 'UA-146071783-1', 'auto');
__gaTracker('set', 'forceSSL', true);
__gaTracker('require', 'displayfeatures');
__gaTracker('send','pageview');
} else {
console.log( "" );
(function() {
/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
var noopfn = function() {
return null;
};
var noopnullfn = function() {
return null;
};
var Tracker = function() {
return null;
};
var p = Tracker.prototype;
p.get = noopfn;
p.set = noopfn;
p.send = noopfn;
var __gaTracker = function() {
var len = arguments.length;
if ( len === 0 ) {
return;
}
var f = arguments[len-1];
if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
return;
}
try {
f.hitCallback();
} catch (ex) {
}
};
__gaTracker.create = function() {
return new Tracker();
};
__gaTracker.getByName = noopnullfn;
__gaTracker.getAll = function() {
return [];
};
__gaTracker.remove = noopfn;
window['__gaTracker'] = __gaTracker;
})();
}</script>  <script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/net2.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.2"}};
!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);</script> <!-- <link rel='stylesheet' id='oceanwp-style-css'  href='https://net2.com/wp-content/uploads/oceanwp/main-style.css?ver=1.7.4' type='text/css' media='all' /> -->
<link rel="stylesheet" type="text/css" href="//net2.com/wp-content/cache/wpfc-minified/9husq3eh/43t44.css" media="all"/> <script type='text/javascript'>var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"}]","home_url":"https:\/\/net2.com","hash_tracking":"false"};</script> <script src='//net2.com/wp-content/cache/wpfc-minified/6y229veg/43t44.js' type="text/javascript"></script>
<!-- <script type='text/javascript' src='https://net2.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend.min.js?ver=7.10.3'></script> --> <!-- <script type='text/javascript' src='https://net2.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script> --> <!-- <script type='text/javascript' src='https://net2.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script> --> <!-- <script type='text/javascript' src='https://net2.com/wp-content/plugins/add-to-any/addtoany.min.js?ver=1.1'></script> --> <script type='text/javascript'>var wpp_params = {"sampling_active":"0","sampling_rate":"100","ajax_url":"https:\/\/net2.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts\/","ID":"2466","token":"173015ed99","debug":""};</script> <script src='//net2.com/wp-content/cache/wpfc-minified/d3r1ay2k/43t44.js' type="text/javascript"></script>
<!-- <script type='text/javascript' src='https://net2.com/wp-content/plugins/wordpress-popular-posts/public/js/wpp-4.2.0.min.js?ver=4.2.2'></script> --> <link rel='https://api.w.org/' href='https://net2.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://net2.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://net2.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.3.2" /><link rel='shortlink' href='https://net2.com/?p=2466' /><link rel="alternate" type="application/json+oembed" href="https://net2.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnet2.com%2Fhow-to-fix-e-could-not-get-lock-var-lib-dpkg-lock-error-in-ubuntu%2F" /><link rel="alternate" type="text/xml+oembed" href="https://net2.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnet2.com%2Fhow-to-fix-e-could-not-get-lock-var-lib-dpkg-lock-error-in-ubuntu%2F&#038;format=xml" /> <script data-cfasync="false">window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};
(function(d,s,a,b){a=d.createElement(s);b=d.getElementsByTagName(s)[0];a.async=1;a.src="https://static.addtoany.com/menu/page.js";b.parentNode.insertBefore(a,b);})(document,"script");</script> <script data-ad-client="ca-pub-4222719099368092" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <meta name="onesignal" content="wordpress-plugin"/> <script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async></script> <script>window.OneSignal = window.OneSignal || [];
OneSignal.push( function() {
OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };
OneSignal.setDefaultNotificationUrl("https://net2.com");
var oneSignal_options = {};
window._oneSignalInitOptions = oneSignal_options;
oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = '816f511e-5922-47a9-9e88-570bf32478fa';
oneSignal_options['autoRegister'] = true;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "";
oneSignal_options['welcomeNotification']['message'] = "";
oneSignal_options['path'] = "https://net2.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.245258f0-6c6a-439f-986f-895149dbff04";
oneSignal_options['persistNotification'] = true;
oneSignal_options['promptOptions'] = { };
oneSignal_options['notifyButton'] = { };
oneSignal_options['notifyButton']['enable'] = true;
oneSignal_options['notifyButton']['position'] = 'bottom-right';
oneSignal_options['notifyButton']['theme'] = 'default';
oneSignal_options['notifyButton']['size'] = 'medium';
oneSignal_options['notifyButton']['prenotify'] = true;
oneSignal_options['notifyButton']['showCredit'] = true;
oneSignal_options['notifyButton']['text'] = {};
oneSignal_options['autoRegister'] = false;
OneSignal.showHttpPrompt();
OneSignal.init(window._oneSignalInitOptions);
});
function documentInitOneSignal() {
var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");
var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
}
if (document.readyState === 'complete') {
documentInitOneSignal();
}
else {
window.addEventListener("load", function(event){
documentInitOneSignal();
});
}</script> <link rel="icon" href="https://net2.com/wp-content/uploads/2019/08/LOGO-ICON-net2.png" sizes="32x32" /><link rel="icon" href="https://net2.com/wp-content/uploads/2019/08/LOGO-ICON-net2.png" sizes="192x192" /><link rel="apple-touch-icon-precomposed" href="https://net2.com/wp-content/uploads/2019/08/LOGO-ICON-net2.png" /><meta name="msapplication-TileImage" content="https://net2.com/wp-content/uploads/2019/08/LOGO-ICON-net2.png" /></head><body class="post-template-default single single-post postid-2466 single-format-standard wp-custom-logo wp-embed-responsive no-lightbox oceanwp-theme sidebar-mobile default-breakpoint has-sidebar content-right-sidebar post-in-category-linux post-in-category-linux-mint-tips-tricks post-in-category-troubleshooting post-in-category-ubuntu_tips_and_tricks page-header-disabled has-blog-grid"><div id="outer-wrap" class="site clr"><div id="wrap" class="clr"><header id="site-header" class="minimal-header clr" data-height="74" itemscope="itemscope" itemtype="http://schema.org/WPHeader"><div id="site-header-inner" class="clr container"><div id="site-logo" class="clr" itemscope itemtype="http://schema.org/Brand"><div id="site-logo-inner" class="clr"> <a href="https://net2.com/" class="custom-logo-link" rel="home"><img width="153" height="89" src="https://net2.com/wp-content/uploads/2019/08/cropped-LOGO-net2.png" class="custom-logo" alt="net2" srcset="https://net2.com/wp-content/uploads/2019/08/cropped-LOGO-net2.png 1x, https://net2.com/wp-content/uploads/2019/08/LOGO-net2.png 2x" /></a></div></div><div id="site-navigation-wrap" class="clr"><nav id="site-navigation" class="navigation main-navigation clr" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement"><ul id="menu-main_menu" class="main-menu dropdown-menu sf-menu"><li id="menu-item-23" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-23"><a href="https://net2.com/" class="menu-link"><span class="text-wrap">Home</span></a></li><li id="menu-item-2460" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children dropdown menu-item-2460"><a href="https://net2.com/category/linux/" class="menu-link"><span class="text-wrap">Linux <span class="nav-arrow fa fa-angle-down"></span></span></a><ul class="sub-menu"><li id="menu-item-1236" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1236"><a href="https://net2.com/category/linux/ubuntu_tips_and_tricks/" class="menu-link"><span class="text-wrap">Linux Tips &#038; Tricks</span></a></li><li id="menu-item-2461" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2461"><a href="https://net2.com/category/linux/best-apps/" class="menu-link"><span class="text-wrap">Best apps</span></a></li></ul></li><li id="menu-item-3044" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3044"><a href="https://net2.com/category/web_hosting/" class="menu-link"><span class="text-wrap">Web hosting</span></a></li><li id="menu-item-2457" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2457"><a href="https://net2.com/category/maintenance-and-monitoring/" class="menu-link"><span class="text-wrap">Maintenance and monitoring</span></a></li><li id="menu-item-2458" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2458"><a href="https://net2.com/category/installations/" class="menu-link"><span class="text-wrap">Installations</span></a></li><li id="menu-item-2459" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-2459"><a href="https://net2.com/category/troubleshooting/" class="menu-link"><span class="text-wrap">Troubleshooting</span></a></li><li class="search-toggle-li"><a href="#" class="site-search-toggle search-dropdown-toggle"><span class="icon-magnifier"></span></a></li></ul><div id="searchform-dropdown" class="header-searchform-wrap clr"><form method="get" class="searchform" id="searchform" action="https://net2.com/"> <input type="text" class="field" name="s" id="s" placeholder="Search"> <input type="hidden" name="post_type" value="post"></form></div></nav></div><div class="oceanwp-mobile-menu-icon clr mobile-right"> <a href="#" class="mobile-menu"> <i class="fa fa-bars"></i> <span class="oceanwp-text">Menu</span> </a></div></div></header><main id="main" class="site-main clr" ><div id="content-wrap" class="container clr"><div id="primary" class="content-area clr"><div id="content" class="site-content clr"><article id="post-2466"><header class="entry-header clr"><h2 class="single-post-title entry-title" itemprop="headline">How to fix ‘E: Could not get lock /var/lib/dpkg/lock’ Error in Ubuntu</h2></header><ul class="meta clr"><li class="meta-author" itemprop="name"><i class="icon-user"></i><a href="https://net2.com/author/aminn2000/" title="Posts by amin nahdy" rel="author"  itemprop="author" itemscope="itemscope" itemtype="http://schema.org/Person">amin nahdy</a></li><li class="meta-date" itemprop="datePublished"><i class="icon-clock"></i>January 28, 2020</li><li class="meta-cat"><i class="icon-folder"></i><a href="https://net2.com/category/linux/" rel="category tag">Linux</a> <span class="owp-sep">/</span> <a href="https://net2.com/category/linux/linux-mint-tips-tricks/" rel="category tag">Linux Mint tips &amp; tricks</a> <span class="owp-sep">/</span> <a href="https://net2.com/category/troubleshooting/" rel="category tag">Troubleshooting</a> <span class="owp-sep">/</span> <a href="https://net2.com/category/linux/ubuntu_tips_and_tricks/" rel="category tag">Ubuntu Tips &amp; Tricks</a></li><li class="meta-comments"><i class="icon-bubble"></i><a href="https://net2.com/how-to-fix-e-could-not-get-lock-var-lib-dpkg-lock-error-in-ubuntu/#respond" class="comments-link local" >0 Comments</a></li></ul><div class="entry-content clr" itemprop="text"><p><span style="color: #000000;">Sometimes when users try to install an application by executing the usual apt command on Ubuntu, they get the following error:</span><span id="more-2466"></span></p><p><span style="color: #000000;"><img class="wp-image-2467 aligncenter" src="https://net2.com/wp-content/uploads/2019/12/word-image.jpeg" srcset="https://net2.com/wp-content/uploads/2019/12/word-image.jpeg 1556w, https://net2.com/wp-content/uploads/2019/12/word-image-300x30.jpeg 300w, https://net2.com/wp-content/uploads/2019/12/word-image-768x78.jpeg 768w, https://net2.com/wp-content/uploads/2019/12/word-image-1024x104.jpeg 1024w" sizes="(max-width: 1556px) 100vw, 1556px" /></span></p><p><span style="color: #000000;">Other users might encounter similar ones like :</span></p><p><span style="color: #000000;"><img class="wp-image-2468 aligncenter" src="https://net2.com/wp-content/uploads/2019/12/word-image-1.jpeg" srcset="https://net2.com/wp-content/uploads/2019/12/word-image-1.jpeg 1556w, https://net2.com/wp-content/uploads/2019/12/word-image-1-300x53.jpeg 300w, https://net2.com/wp-content/uploads/2019/12/word-image-1-768x135.jpeg 768w, https://net2.com/wp-content/uploads/2019/12/word-image-1-1024x180.jpeg 1024w" sizes="(max-width: 1556px) 100vw, 1556px" /></span></p><p><span style="color: #000000;">In this article we will shall provide some effective methods to get rid of this kind of errors.</span></p><h3><span style="color: #000000;"><a id="post-2466-_kobo478y42dn" style="color: #000000;" rel="nofollow"></a>1 &#8211; Identify and kill all apt or apt-get related processes</span></h3><p><span style="color: #000000;">This error can occur due to several reasons. Since this is a locking situation, it could be that the <span style="color: #3366ff;"><a style="color: #3366ff;" href="https://net2.com/how-to-use-the-apt-command-in-ubuntu-debian-linux-systems/" target="_blank" rel="noopener noreferrer">apt</a> </span>or <span style="color: #3366ff;"><a style="color: #3366ff;" href="https://net2.com/how-to-use-the-apt-command-in-ubuntu-debian-linux-systems/" target="_blank" rel="noopener noreferrer">apt-get</a></span> commands are being used by some other processes preventing therefore other programs from using them. Some applications like Synaptic Package Manager or Ubuntu Software Center are using this package management utility.</p><p><span style="color: #3366ff;"><strong><span style="font-size: 12pt;">Read : <a style="color: #3366ff;" href="https://net2.com/how-to-install-and-uninstall-applications-in-ubuntu-a-beginners-guide/" target="_blank" rel="noopener noreferrer">How to install and uninstall applications on Ubuntu ; A Beginner’s guide</a></span></strong></span><br /> </span><span style="color: #000000;"><br /> It won’t actually harm to kill an apt or aptitude process unless it is currently performing a package installation. Killing a dpkg process however might not be a good idea, since if dpkg is currently active, .i.e. manipulating the package database, the package database will become inconsistent or in other words corrupted.</span></p><p><span style="color: #000000;">To kill the processes that are using the apt tool, run the command below:</span></p><p><span style="color: #000000; font-family: 'courier new', courier, monospace;">ps aux | grep -i apt</span></p><p><span style="color: #000000;"><img class="wp-image-2469 aligncenter" src="https://net2.com/wp-content/uploads/2019/12/word-image-2.jpeg" srcset="https://net2.com/wp-content/uploads/2019/12/word-image-2.jpeg 1556w, https://net2.com/wp-content/uploads/2019/12/word-image-2-300x30.jpeg 300w, https://net2.com/wp-content/uploads/2019/12/word-image-2-768x76.jpeg 768w, https://net2.com/wp-content/uploads/2019/12/word-image-2-1024x101.jpeg 1024w" sizes="(max-width: 1556px) 100vw, 1556px" /></span></p><p><span style="color: #000000;">The id of the process which invokes apt or apt-get is displayed above, .i.e. 24623. We will now kill this process in order to release the lock using the <span style="color: #3366ff;"><a style="color: #3366ff;" href="https://net2.com/how-to-create-a-sudo-user-on-ubuntu/" target="_blank" rel="noopener noreferrer">sudo</a></span> command below:</span></p><p><span style="color: #000000; font-family: 'courier new', courier, monospace;">sudo kill -9 24653</span></p><p><span style="color: #000000;">In your case, just plug in the process id that you obtained above.</span></p><p><span style="color: #000000;">Another alternative would be to kill all instances of the programs that are running apt or apt-get using killall:</span></p><p><span style="color: #000000; font-family: 'courier new', courier, monospace;">sudo killall apt apt-get</span></p><h3><span style="color: #000000;"><a id="post-2466-_wxo5khtlzoqy" style="color: #000000;" rel="nofollow"></a>2 &#8211; Remove the lock file</span></h3><p><span style="color: #000000;">In case you had no other processes running apt or apt-get commands in your current session, then the problem might be caused by the lock file that was created at some time in the past due for instance to apt processes not terminated properly.</p><p><span style="color: #3366ff; font-size: 12pt;"><strong>Read: <a style="color: #3366ff;" href="https://net2.com/how-to-speed-up-linux/" target="_blank" rel="noopener noreferrer">How to speed up Linux</a></strong></span></span></p><p><span style="color: #000000;">Since the lock files are still around, we should first make sure no other process is using it before removing it. This is because it is not good practice to remove the lock file without terminating the program that&#8217;s holding the lock first, since this could interrupt an ongoing installation or cause corruption.</span></p><p><span style="color: #000000;">In order to identify the process that owns the lock file, we will use the command lsof as shown below :</span></p><p><span style="font-family: 'courier new', courier, monospace;"><span style="color: #000000;">lsof /var/lib/dpkg/lock<br /> </span><span style="color: #000000;">lsof /var/lib/apt/lists/lock<br /> </span><span style="color: #000000;">lsof /var/cache/apt/archives/lock</span></span></p><p><span style="color: #000000;">The output might look like the following :</span></p><p><span style="color: #000000;"><img class="wp-image-2470" src="https://net2.com/wp-content/uploads/2019/12/word-image.png" srcset="https://net2.com/wp-content/uploads/2019/12/word-image.png 1340w, https://net2.com/wp-content/uploads/2019/12/word-image-300x22.png 300w, https://net2.com/wp-content/uploads/2019/12/word-image-768x57.png 768w, https://net2.com/wp-content/uploads/2019/12/word-image-1024x76.png 1024w" sizes="(max-width: 1340px) 100vw, 1340px" /></span></p><p><span style="color: #000000;">If one of these commands returns a result, it will display the process id that owns the lock file. The PID shown above is 12127. Go ahead and run the kill command below :</span></p><p><span style="color: #000000; font-family: 'courier new', courier, monospace;">sudo kill -9 12127</span></p><p><span style="color: #000000;">You can now remove the lock file with the command:</span></p><p><span style="color: #000000; font-family: 'courier new', courier, monospace;">sudo rm /var/lib/apt/lists/lock</span></p><p><span style="color: #000000;">You may also have to delete the lock file in the cache directory by running the commands:</span></p><p><span style="font-family: 'courier new', courier, monospace;"><span style="color: #000000;">sudo rm /var/cache/apt/archives/lock<br /> </span><span style="color: #000000;">sudo rm /var/lib/dpkg/lock</span></span></p><h2><span style="color: #000000;">Conclusion</span></h2><p><span style="color: #000000;"><span style="font-weight: 400;">We have provided two methods to deal with a rather common problem faced by many users on Ubuntu and similar distros when they run apt or </span><span style="font-weight: 400;">apt-get</span> <span style="font-weight: 400;">. This is the lock issue that prevents other processes from executing these installation commands. Terminating these processes or removing the lock file can help solve this problem.<br /> </span></span><span style="font-weight: 400; color: #000000;">In case you have other methods that help solve this error, do not hesitate to share it with us.</span></p></div><section id="author-bio" class="clr"><div id="author-bio-inner"><div class="author-bio-avatar"> <a href="https://net2.com/author/aminn2000/" title="Visit Author Page" rel="author" > <img alt='' src='https://secure.gravatar.com/avatar/49524b8fd27a4dce906f9bdb13f6d693?s=100&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/49524b8fd27a4dce906f9bdb13f6d693?s=200&#038;d=mm&#038;r=g 2x' class='avatar avatar-100 photo' height='100' width='100' /> </a></div><div class="author-bio-content clr"><h4 class="author-bio-title"> <a href="https://net2.com/author/aminn2000/" title="Visit Author Page"> amin nahdy </a></h4><div class="author-bio-description clr"> Amin Nahdy, an aspiring software engineer and a computer geek by nature as well as an avid Ubuntu and open source user. He is interested in information technology especially Ubuntu and Linux based ecosystem. He loves to share and disseminate knowledge to others in a transparent and responsible way.</div></div></div></section><div class="post-tags clr"> <span class="owp-tag-text">Tags: </span><a href="https://net2.com/tag/apt-lock-issue/" rel="tag">apt lock issue</a><span class="owp-sep">,</span> <a href="https://net2.com/tag/kill-process/" rel="tag">kill process</a><span class="owp-sep">,</span> <a href="https://net2.com/tag/lsof-command/" rel="tag">lsof command</a></div><nav class="navigation post-navigation" role="navigation" aria-label="Continue Reading"><h2 class="screen-reader-text">Continue Reading</h2><div class="nav-links"><div class="nav-previous"><a href="https://net2.com/how-to-display-files-sizes-in-mb-in-linux-ubuntu/" rel="prev"><span class="title"><i class="fas fa-long-arrow-alt-left"></i>Previous Post</span><span class="post-title">How to display files sizes in MB in Linux/Ubuntu</span></a></div></div></nav><section id="related-posts" class="clr"><h3 class="theme-heading related-posts-title"> <span class="text">You Might Also Like</span></h3><div class="oceanwp-row clr"><article class="related-post clr col span_1_of_3 col-1 post-1421 post type-post status-publish format-standard has-post-thumbnail hentry category-linux category-maintenance-and-monitoring category-ubuntu tag-cpu-usage tag-htop-monitoring-tool tag-kill-process tag-memory-usage tag-process-monitoring tag-process-monitoring-gui entry has-media"><figure class="related-post-media clr"> <a href="https://net2.com/monitoring-system-processes-in-ubuntu-using-htop/" class="related-thumb"> <img src="https://net2.com/wp-content/uploads/2019/09/Monitoring-system-processes-iusing-htop-352x235.jpg" alt="Monitoring system processes in Ubuntu using htop." width="352" height="235" itemprop="image" /> </a></figure><h3 class="related-post-title"> <a href="https://net2.com/monitoring-system-processes-in-ubuntu-using-htop/" title="Monitoring system processes in Ubuntu using htop." rel="bookmark">Monitoring system processes in Ubuntu using htop.</a></h3> <time class="published" datetime="2019-10-23T16:31:34+02:00"><i class="icon-clock"></i>October 23, 2019</time></article><article class="related-post clr col span_1_of_3 col-2 post-1662 post type-post status-publish format-standard has-post-thumbnail hentry category-debian category-linux category-linux_mint category-maintenance-and-monitoring category-troubleshooting category-ubuntu tag-proc-sys-vm-overcommit_memory tag-proc-sys-vm-overcommit_ratio tag-htop-command tag-kill-process tag-memory-overcommit tag-out-of-memory tag-ps-command tag-sar-tool tag-top-command tag-vmstat entry has-media"><figure class="related-post-media clr"> <a href="https://net2.com/how-to-fix-high-memory-usage-in-linux/" class="related-thumb"> <img src="https://net2.com/wp-content/uploads/2019/10/How-to-fix-high-memory-usage-in-Linux--352x235.jpg" alt="How to fix high memory usage in Linux" width="352" height="235" itemprop="image" /> </a></figure><h3 class="related-post-title"> <a href="https://net2.com/how-to-fix-high-memory-usage-in-linux/" title="How to fix high memory usage in Linux" rel="bookmark">How to fix high memory usage in Linux</a></h3> <time class="published" datetime="2019-10-13T09:05:04+02:00"><i class="icon-clock"></i>October 13, 2019</time></article></div></section><section id="comments" class="comments-area clr"><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/how-to-fix-e-could-not-get-lock-var-lib-dpkg-lock-error-in-ubuntu/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://net2.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><div class="comment-textarea"><textarea name="comment" id="comment" cols="39" rows="4" tabindex="100" class="textarea-comment" placeholder="Your Comment Here..."></textarea></div><div class="comment-form-author"><input type="text" name="author" id="author" value="" placeholder="Name (required)" size="22" tabindex="101" aria-required="true" class="input-name" /></div><div class="comment-form-email"><input type="text" name="email" id="email" value="" placeholder="Email (required)" size="22" tabindex="102" aria-required="true" class="input-email" /></div><div class="comment-form-url"><input type="text" name="url" id="url" value="" placeholder="Website" size="22" tabindex="103" class="input-website" /></div><p class="form-submit"><input name="submit" type="submit" id="comment-submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='2466' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="748bc97948" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="157"/></p></form></div></section></article></div></div><aside id="right-sidebar" class="sidebar-container widget-area sidebar-primary" itemscope="itemscope" itemtype="http://schema.org/WPSideBar"><div id="right-sidebar-inner" class="clr"><div id="search-2" class="sidebar-box widget_search clr"><h4 class="widget-title">Search</h4><form method="get" class="searchform" id="searchform" action="https://net2.com/"> <input type="text" class="field" name="s" id="s" placeholder="Search"> <input type="hidden" name="post_type" value="post"></form></div><div id="recent-posts-2" class="sidebar-box widget_recent_entries clr"><h4 class="widget-title">Recent Posts</h4><ul><li> <a href="https://net2.com/how-to-fix-e-could-not-get-lock-var-lib-dpkg-lock-error-in-ubuntu/" aria-current="page">How to fix ‘E: Could not get lock /var/lib/dpkg/lock’ Error in Ubuntu</a></li><li> <a href="https://net2.com/best-web-hosting-services-for-2020/">Best Web Hosting services for 2020</a></li><li> <a href="https://net2.com/how-to-display-files-sizes-in-mb-in-linux-ubuntu/">How to display files sizes in MB in Linux/Ubuntu</a></li><li> <a href="https://net2.com/how-is-the-path-environment-variable-managed-in-linux-ubuntu-debian/">How is the path environment variable managed in Linux/Ubuntu/Debian?</a></li><li> <a href="https://net2.com/blue-light-from-your-computer-or-phone-could-damage-your-eyes/">Blue light from your computer or phone could damage your eyes</a></li></ul></div><div id="wpp-4" class="sidebar-box popular-posts clr"><h4 class="widget-title">Most Popular posts</h4><ul class="wpp-list"><li> <a href="https://net2.com/how-to-fix-wifi-not-working-on-ubuntu/" title="How to fix WiFi not working on Ubuntu" class="wpp-post-title" target="_self">How to fix WiFi not working on Ubuntu</a></li><li> <a href="https://net2.com/how-to-speed-up-linux/" title="How to speed up Linux" class="wpp-post-title" target="_self">How to speed up Linux</a></li><li> <a href="https://net2.com/how-to-fix-high-memory-usage-in-linux/" title="How to fix high memory usage in Linux" class="wpp-post-title" target="_self">How to fix high memory usage in Linux</a></li><li> <a href="https://net2.com/how-to-fix-unmet-dependencies-error-in-ubuntu/" title="How to Fix Unmet Dependencies Error on Ubuntu" class="wpp-post-title" target="_self">How to Fix Unmet Dependencies Error on Ubuntu</a></li><li> <a href="https://net2.com/how-to-find-the-largest-files-on-linux/" title="How to find the largest files on Linux" class="wpp-post-title" target="_self">How to find the largest files on Linux</a></li><li> <a href="https://net2.com/how-to-copy-a-file-to-multiple-directories-in-linux/" title="How to copy a file to multiple directories in Linux" class="wpp-post-title" target="_self">How to copy a file to multiple directories in Linux</a></li><li> <a href="https://net2.com/how-to-merge-or-split-pdf-files-on-linux/" title="How to merge or split PDF files on Linux" class="wpp-post-title" target="_self">How to merge or split PDF files on Linux</a></li><li> <a href="https://net2.com/how-to-list-start-and-stop-services-at-boot-time-in-linux-ubuntu-debian/" title="How to list, start and stop services at boot time in Linux Ubuntu/Debian" class="wpp-post-title" target="_self">How to list, start and stop services at boot time in Linux Ubuntu/Debian</a></li><li> <a href="https://net2.com/moving-the-home-folder-to-another-partition-in-ubuntu/" title="Moving the Home folder to another partition in Ubuntu" class="wpp-post-title" target="_self">Moving the Home folder to another partition in Ubuntu</a></li><li> <a href="https://net2.com/how-to-fix-ubuntu-boot-issues/" title="How to fix Ubuntu boot issues" class="wpp-post-title" target="_self">How to fix Ubuntu boot issues</a></li></ul></div><div id="a2a_follow_widget-3" class="sidebar-box widget_a2a_follow_widget clr"><div class="a2a_kit a2a_kit_size_32 a2a_follow addtoany_list"><a class="a2a_button_facebook" href="https://www.facebook.com/aminnahdy.net2/" title="Facebook" rel="noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://twitter.com/Amin_net2" title="Twitter" rel="noopener" target="_blank"></a><a class="a2a_button_pinterest" href="https://www.pinterest.fr/Amin_net2/" title="Pinterest" rel="noopener" target="_blank"></a></div></div><div id="newsletterwidgetminimal-2" class="sidebar-box widget_newsletterwidgetminimal clr"><h4 class="widget-title">Stay informed by joining our newsletter!</h4><div class="tnp tnp-widget-minimal"><form class="tnp-form" action="https://net2.com/?na=s" method="post" onsubmit="return newsletter_check(this)"><input type="hidden" name="nr" value="widget-minimal"/><input class="tnp-email" type="email" required name="ne" value="" placeholder="Email"><input class="tnp-submit" type="submit" value="Subscribe"></form></div></div></div></aside></div></main><footer id="footer" class="site-footer" itemscope="itemscope" itemtype="http://schema.org/WPFooter"><div id="footer-inner" class="clr"><div id="footer-widgets" class="oceanwp-row clr"><div class="footer-widgets-inner container"><div class="footer-box span_1_of_4 col col-1"><div id="custom_html-2" class="widget_text footer-widget widget_custom_html clr"><div class="textwidget custom-html-widget"><a class="maxbutton-1 maxbutton maxbutton-joinnet2redditcommunity" target="_blank" rel="nofollow noopener noreferrer" href="https://reddit.com/r/net2"><span class='mb-text'>Join net2@Reddit</span></a></div></div></div><div class="footer-box span_1_of_4 col col-2"></div><div class="footer-box span_1_of_4 col col-3 "></div><div class="footer-box span_1_of_4 col col-4"></div></div></div><div id="footer-bottom" class="clr"><div id="footer-bottom-inner" class="container clr"><div id="footer-bottom-menu" class="navigation clr"><div class="menu-footer-container"><ul id="menu-footer" class="menu"><li id="menu-item-2384" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2384"><a href="https://net2.com/convert-pdf-to-word/">Convert pdf to word for FREE</a></li><li id="menu-item-28" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28"><a href="https://net2.com/contact-us/">Contact us</a></li><li id="menu-item-29" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29"><a href="https://net2.com/about/">About</a></li><li id="menu-item-30" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-30"><a href="https://net2.com/privacy-policy/">Privacy Policy</a></li></ul></div></div><div id="copyright" class="clr" role="contentinfo"> Copyright net2.com all rights reserved 2019</div></div></div></div></footer></div></div><div id="sidr-close"> <a href="#" class="toggle-sidr-close"> <i class="icon icon-close"></i><span class="close-text">Close Menu</span> </a></div><div id="mobile-nav" class="navigation clr"><ul id="menu-main_menu-1" class="mobile-menu dropdown-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-23"><a href="https://net2.com/">Home</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-2460"><a href="https://net2.com/category/linux/">Linux</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1236"><a href="https://net2.com/category/linux/ubuntu_tips_and_tricks/">Linux Tips &#038; Tricks</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2461"><a href="https://net2.com/category/linux/best-apps/">Best apps</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3044"><a href="https://net2.com/category/web_hosting/">Web hosting</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2457"><a href="https://net2.com/category/maintenance-and-monitoring/">Maintenance and monitoring</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2458"><a href="https://net2.com/category/installations/">Installations</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-2459"><a href="https://net2.com/category/troubleshooting/">Troubleshooting</a></li></ul></div><div id="mobile-menu-search" class="clr"><form method="get" action="https://net2.com/" class="mobile-searchform"> <input type="search" name="s" autocomplete="off" placeholder="Search" /> <button type="submit" class="searchform-submit"> <i class="icon icon-magnifier"></i> </button> <input type="hidden" name="post_type" value="post"></form></div><div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_default_style" data-a2a-scroll-show="100" style="bottom:50px;left:0px;background-color:transparent;"><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div><!--noptimize--><!--email_off--><style type='text/css'>.maxbutton-1.maxbutton.maxbutton-joinnet2redditcommunity{position:relative;text-decoration:none;display:inline-block;vertical-align:middle;border-color:#000;width:160px;height:40px;border-top-left-radius:4px;border-top-right-radius:4px;border-bottom-left-radius:4px;border-bottom-right-radius:4px;border-style:solid;border-width:2px;background-color:rgba(0, 0, 0, 1);-webkit-box-shadow:0px 0px 2px 0px #333;-moz-box-shadow:0px 0px 2px 0px #333;box-shadow:0px 0px 2px 0px #333}.maxbutton-1.maxbutton.maxbutton-joinnet2redditcommunity:hover{border-color:#000;background-color:rgba(255, 255, 255, 1);-webkit-box-shadow:0px 0px 2px 0px #333;-moz-box-shadow:0px 0px 2px 0px #333;box-shadow:0px 0px 2px 0px #333}.maxbutton-1.maxbutton.maxbutton-joinnet2redditcommunity .mb-text{color:#fff;font-family:Tahoma;font-size:15px;text-align:center;font-style:normal;font-weight:normal;padding-top:12px;padding-right:0px;padding-bottom:0px;padding-left:0px;line-height:1em;box-sizing:border-box;display:block;background-color:unset}.maxbutton-1.maxbutton.maxbutton-joinnet2redditcommunity:hover .mb-text{color:#000}
</style><!--/email_off--><!--/noptimize--><div id="wpfront-scroll-top-container"> <img src="https://net2.com/wp-content/plugins/wpfront-scroll-top/images/icons/1.png" alt="" /></div> <script type="text/javascript">function wpfront_scroll_top_init() {if(typeof wpfront_scroll_top == "function" && typeof jQuery !== "undefined") {wpfront_scroll_top({"scroll_offset":100,"button_width":0,"button_height":0,"button_opacity":0.8000000000000000444089209850062616169452667236328125,"button_fade_duration":200,"scroll_duration":400,"location":2,"marginX":20,"marginY":20,"hide_iframe":false,"auto_hide":false,"auto_hide_after":2,"button_action":"top","button_action_element_selector":"","button_action_container_selector":"html, body","button_action_element_offset":0});} else {setTimeout(wpfront_scroll_top_init, 100);}}wpfront_scroll_top_init();</script><script type='text/javascript'>var wpcf7 = {"apiSettings":{"root":"https:\/\/net2.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};</script> <script type='text/javascript' src='https://net2.com/wp-content/cache/autoptimize/js/autoptimize_single_1534f06aa2b1b721a45372f8238e2461.js?ver=5.1.4'></script> <script type='text/javascript' src='https://net2.com/wp-content/plugins/wpfront-scroll-top/js/wpfront-scroll-top.min.js?ver=2.0.2'></script> <script type='text/javascript' src='https://www.google.com/recaptcha/api.js?render=6LfC3LIUAAAAAPuQlovhyPa52-7pFt0hAH8Z760b&#038;ver=3.0'></script> <script type='text/javascript' src='https://net2.com/wp-includes/js/comment-reply.min.js?ver=5.3.2'></script> <script type='text/javascript' src='https://net2.com/wp-includes/js/imagesloaded.min.js?ver=3.2.0'></script> <script type='text/javascript'>var q2w3_sidebar_options = [{"sidebar":"sidebar","margin_top":20,"margin_bottom":0,"stop_id":"footer","screen_max_width":0,"screen_max_height":0,"width_inherit":false,"refresh_interval":1500,"window_load_hook":false,"disable_mo_api":false,"widgets":["wpp-4","a2a_follow_widget-3","newsletterwidgetminimal-2"]}];</script> <script type='text/javascript' src='https://net2.com/wp-content/plugins/q2w3-fixed-widget/js/q2w3-fixed-widget.min.js?ver=5.1.9'></script> <script type='text/javascript'>var newsletter = {"messages":{"email_error":"Email address is not correct","name_error":"Name is required","surname_error":"Last name is required","privacy_error":"You must accept the privacy policy"},"profile_max":"20"};</script> <script type='text/javascript' src='https://net2.com/wp-content/cache/autoptimize/js/autoptimize_single_b562667fe2faa8b03924bed00a98d7ec.js?ver=6.1.6'></script> <script type='text/javascript'>var oceanwpLocalize = {"isRTL":"","menuSearchStyle":"drop_down","sidrSource":"#sidr-close, #mobile-nav, #mobile-menu-search","sidrDisplace":"1","sidrSide":"left","sidrDropdownTarget":"icon","verticalHeaderTarget":"icon","customSelects":".woocommerce-ordering .orderby, #dropdown_product_cat, .widget_categories select, .widget_archive select, .single-product .variations_form .variations select","ajax_url":"https:\/\/net2.com\/wp-admin\/admin-ajax.php"};</script> <script type='text/javascript' src='https://net2.com/wp-content/cache/autoptimize/js/autoptimize_single_4764ccf1821b5441e9e41f3ba9106801.js?ver=1.7.4'></script> <script type='text/javascript' src='https://net2.com/wp-includes/js/wp-embed.min.js?ver=5.3.2'></script> <!--[if lt IE 9]> <script type='text/javascript' src='https://net2.com/wp-content/themes/oceanwp/assets/js//third/html5.min.js?ver=1.7.4'></script> <![endif]--> <script async="async" type='text/javascript' src='https://net2.com/wp-content/cache/autoptimize/js/autoptimize_single_270f0cd7341bce6c2afacf2682e7690e.js?ver=4.1.2'></script> <script type="text/javascript">( function( grecaptcha, sitekey, actions ) {
var wpcf7recaptcha = {
execute: function( action ) {
grecaptcha.execute(
sitekey,
{ action: action }
).then( function( token ) {
var forms = document.getElementsByTagName( 'form' );
for ( var i = 0; i < forms.length; i++ ) {
var fields = forms[ i ].getElementsByTagName( 'input' );
for ( var j = 0; j < fields.length; j++ ) {
var field = fields[ j ];
if ( 'g-recaptcha-response' === field.getAttribute( 'name' ) ) {
field.setAttribute( 'value', token );
break;
}
}
}
} );
},
executeOnHomepage: function() {
wpcf7recaptcha.execute( actions[ 'homepage' ] );
},
executeOnContactform: function() {
wpcf7recaptcha.execute( actions[ 'contactform' ] );
},
};
grecaptcha.ready(
wpcf7recaptcha.executeOnHomepage
);
document.addEventListener( 'change',
wpcf7recaptcha.executeOnContactform, false
);
document.addEventListener( 'wpcf7submit',
wpcf7recaptcha.executeOnHomepage, false
);
} )(
grecaptcha,
'6LfC3LIUAAAAAPuQlovhyPa52-7pFt0hAH8Z760b',
{"homepage":"homepage","contactform":"contactform"}
);</script> </body></html><!-- WP Fastest Cache file was created in 0.23433899879456 seconds, on 28-01-20 20:29:45 -->